ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bandeep Singh <bsi...@phemi.com>
Subject Re: Trouble loading AE
Date Tue, 27 Sep 2016 20:09:17 GMT
Can you share the complete stack trace (error logs). And may be we will
know what is going on.


On Tue, Sep 27, 2016 at 12:47 PM, Gianfrancesco, Milena <
Milena.Gianfrancesco@ucsf.edu> wrote:

> Thanks, yes, so I am getting this error message in response to loading the
> AE even though resources have been downloaded as specified in the User
> Manuel. Any other thoughts as to why this may be occurring? Do any of the
> files within the resources folder need to be modified before loading?
>
>
> From: Bandeep Singh <bsingh@phemi.com>
> Reply-To: "user@ctakes.apache.org" <user@ctakes.apache.org>
> Date: Tuesday, September 27, 2016 at 11:55 AM
>
> To: "user@ctakes.apache.org" <user@ctakes.apache.org>
> Subject: Re: Trouble loading AE
>
> Hi Milena,
>
> I am referring to the same resources mentioned in the User Install Guide
> doc.
>
>
> -Bandeep
>
> On Tue, Sep 27, 2016 at 11:05 AM, Gianfrancesco, Milena <
> Milena.Gianfrancesco@ucsf.edu> wrote:
>
>> Hi Bandeep,
>>
>> I downloaded resources as instructed in the User Install Guide and copied
>> them into the resources folder. Is that what you are referring to? Or it
>> there another set of UMLS resources to be downloaded? There didn’t appear
>> to be so in the link.
>>
>> Thanks
>>
>> From: Bandeep Singh <bsingh@phemi.com>
>> Reply-To: "user@ctakes.apache.org" <user@ctakes.apache.org>
>> Date: Wednesday, September 21, 2016 at 3:54 PM
>> To: "user@ctakes.apache.org" <user@ctakes.apache.org>
>>
>> Subject: Re: Trouble loading AE
>>
>> Hi,
>> Glad that it worked !
>>
>> I think resources are missing in your cTakes installation.
>> Did you download the UMLS resources separately from
>> https://sourceforge.net/projects/ctakesresources/files/?source=navbar
>> And You have to put these resources under *org/apache/ctakes/dictionary/*
>>
>> Hope that Helps !
>>
>> Bandeep
>>
>> On Wed, Sep 21, 2016 at 3:45 PM, Gianfrancesco, Milena <
>> Milena.Gianfrancesco@ucsf.edu> wrote:
>>
>>> Thanks, Bandeep. That seems to have solved that issue, but now when I
>>> try to load AE I get an error message popup that states:
>>> "org.apache.uima.resource.ResourceInitializationException". I'm not
>>> sure what this means? It only happens when I try to load the AEs that
>>> utilize UMLS.
>>>
>>> Thanks in advance.
>>>
>>>
>>>
>>> ------------------------------
>>> *From:* Bandeep Singh [bsingh@phemi.com]
>>> *Sent:* Tuesday, September 13, 2016 5:24 PM
>>> *To:* user@ctakes.apache.org
>>> *Subject:* Re: Trouble loading AE
>>>
>>> Hi Milena,
>>>
>>> It looks like a classic example of Java version mismatch. One of the
>>> dependencies of cTakes is Java 8
>>> Please make sure you have JAVA SDK installed and not JRE. I have OpenJDK
>>> 8 running on my system and cTakes runs fine on my system.
>>>
>>>  -Bandeep
>>>
>>> On Tue, Sep 13, 2016 at 2:32 PM, Gianfrancesco, Milena <
>>> Milena.Gianfrancesco@ucsf.edu> wrote:
>>>
>>>> Hello,
>>>>
>>>> I have just installed cTakes and followed instructions in the 3.2 User
>>>> Install Guide. However, I am unable to load an AE. I have a UMLS user name
>>>> and password, and have updated the appropriate scripts as outlined in the
>>>> User Guide, yet I get this error when trying to load any AE (even the
>>>> non-UMLS ones):
>>>>
>>>> Exception in thread "AWT-EventQueue-0" java.lang.UnsupportedClassVersionError:
>>>> org/apache/ctakes/dependency/parser/ae/ClearNLPDependencyParserAE :
>>>> Unsupported major.minor version 51.0
>>>>
>>>> at java.lang.ClassLoader.defineClass1(Native Method)
>>>>
>>>> at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
>>>>
>>>> at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
>>>>
>>>> at java.security.SecureClassLoader.defineClass(SecureClassLoade
>>>> r.java:141)
>>>>
>>>> at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
>>>>
>>>> at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
>>>>
>>>> at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
>>>>
>>>> at java.security.AccessController.doPrivileged(Native Method)
>>>>
>>>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>>>>               …… + more
>>>>
>>>>  I have double checked that I have the latest Java software. Any idea
>>>> what could be causing this error?
>>>>
>>>> Thank you!
>>>>
>>>> Milena
>>>>
>>>
>>>
>>
>

Mime
View raw message