ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Braun, Florian A" <fbr...@fredhutch.org>
Subject RE: smoking status - TypeSystem.xml could not be found
Date Wed, 22 Jul 2015 19:42:36 GMT
Wow, was just about to send an email on this. I am getting the exact same error.

I found the xml file under <ctakes-home>\ctakes-smoking-status\src\main\resources\org\apache\ctakes\smokingstatus\types\

Looks like it has an issue being under resources and not under the java?

Any info would be appreciated.

Florian

From: Justin Zhang [mailto:justinzhang.xl@gmail.com]
Sent: Wednesday, July 22, 2015 10:54 AM
To: user@ctakes.apache.org
Subject: smoking status - TypeSystem.xml could not be found

When I ran smoking pipeline from Eclipse, encountered the following error.

Caused by: org.apache.uima.util.InvalidXMLException: An import could not be resolved.  No
.xml file with name "org.apache.ctakes.smokingstatus.types.TypeSystem" was found in the class
path or data path. (Descriptor: file:/Users/justin/App/eclipse_mars/workspace_eclipse_mars/ctakes/ctakes-smoking-status/desc/analysis_engine/ClassifiableEntriesAnnotator.xml)

Everything looks fine.

The file is there physically.
The importing part from ClassifiableEntriesAnnotator.xml file is
 <typeSystemDescription>
      <imports>
                        <import name="org.apache.ctakes.smokingstatus.types.TypeSystem"/>
      </imports>
    </typeSystemDescription>

Could any one help me some clues?

Thanks,


--
Justin
Mime
View raw message