ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Weiwei Zhang <wzhan...@dons.usfca.edu>
Subject Re: Collection Processing Engine (CPE) Exception, User Install
Date Thu, 29 Jan 2015 19:04:31 GMT
Hi Pei,

Thank you for your response. I added the imports to the CdaCasInitializer
descriptor but I am still getting the same error as follows,

[image: Inline image 1]

There might be something going wrong with "AggregateCdaProcessor".

Thank you,
Vivian


On Thu, Jan 29, 2015 at 9:37 AM, Pei Chen <chenpei@apache.org> wrote:

> Try adding the below to the earliest defined primitive descriptor? [1][2]
>
> <typeSystemDescription>
>
>        <imports>
>
> <import name="org.apache.ctakes.typesystem.types.TypeSystem"/>
>
>      </imports>
>
> </typeSystemDescription>
>
>
>
> Normally I think this is already added in SegementAnnotator…  Feel free to
> create a Jira (steps to replicate the issue, and where you placed the fix
> so it can be addressed in the next patch).
>
> Side note: I think we should DELETE all existing xml Descriptors (very
> difficult to maintain and test all combinations).  And recreate only the
> necessary ones via uimaFIT.
>
>
>
> [1]
> http://mail-archives.apache.org/mod_mbox/ctakes-user/201311.mbox/%3C1384464005.90860.YahooMailNeo@web140301.mail.bf1.yahoo.com%3E
>
> [2]
> http://mail-archives.apache.org/mod_mbox/ctakes-user/201403.mbox/%3CCAPqz87oUZ=hPzc_Fo_ZLaEf3PVQcm9xSYuMs15iyMgapsxX9gg@mail.gmail.com%3E
>
> On Wed, Jan 28, 2015 at 3:46 PM, Weiwei Zhang <wzhang41@dons.usfca.edu>
> wrote:
>
>> Hello there,
>>
>> I encountered the same error as Tol when running CPE in Apache cTakes.
>>
>> Thank you,
>> Vivian
>>
>> On Wed, Jan 28, 2015 at 12:04 PM, Tol O. <toltox@gmail.com> wrote:
>>
>>> I just tried this test_plaintext.xml file as the CPE descriptor with the
>>> sample file placed in the testdata folder mentioned in the tutorial and
>>> (set the input directory in the GUI to the testdata folder):
>>>
>>> https://svn.apache.org/repos/asf/ctakes/branches/ctakes-3.1.0/ctakes-clinical-pipeline/src/test/data/testpatient_cn_1.xml
>>>
>>> The Error window I am getting states
>>> "org.apache.uima.cas.CASRuntimeException: Jcas type
>>> "org.apache.ctakes.typesystem.type.structured.DocumentID" used in Java
>>> code, but was not declared in the XML type descriptor.
>>>
>>> So still no luck, do you have any other suggestions?
>>>
>>> Tol
>>>
>>>
>>>
>>>
>>>
>>> On Wed, Jan 28, 2015 at 1:42 PM, britt fitch <
>>> britt.fitch@wiredinformatics.com> wrote:
>>>
>>>> Hi Tol, you might prefer to try the test_plaintext.xml CPE instead of
>>>> the CDA one:
>>>>
>>>> http://svn.apache.org/repos/asf/ctakes/trunk/ctakes-clinical-pipeline/desc/collection_processing_engine/test_plaintext.xml
>>>>
>>>>
>>>> Cheers,
>>>>
>>>> Britt
>>>>
>>>>     Britt Fitch
>>>> Wired Informatics
>>>> 265 Franklin St Ste 1702
>>>> Boston, MA 02110
>>>> http://wiredinformatics.com
>>>> Britt.Fitch@wiredinformatics.com
>>>>
>>>> On Jan 28, 2015, at 2:25 PM, Tol O. <toltox@gmail.com> wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am following the cTAKES 3.2 User Install Guide with cTAKES 3.2.1
>>>> using Linux and Java 8.
>>>>
>>>> At step 8 of the Collection Processing Engine (CPE) (click the play
>>>> button) I am get an error message:
>>>> "org.apache.uima.resource.ResourceInitializationException:
>>>> Initialization of CAS Processor with name "AggregateCdaProcessor" failed.
>>>> [...] Caused by: java.lang.IllegalArgumentException: URI is not
>>>> hierarchical."
>>>>
>>>> I read a bit on this mailing list and saw that other people also
>>>> encountered such or a similar error. I followed the install guide step by
>>>> step and extracted/copied the cTAKES resources folder over the already
>>>> existing resources folder of cTAKES.
>>>>
>>>> Does anybody know how to fix this Exception problem to run the
>>>> Collection Processing Engine (CPE)?
>>>>
>>>> Many thanks!
>>>>
>>>>
>>>>
>>>
>>
>

Mime
View raw message