ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kincaid <kincaid.d...@gmail.com>
Subject Re: URI is not hierarchical exception from LvgCmdApiResourceImpl
Date Wed, 26 Nov 2014 21:16:55 GMT
Just to close things up I found the problem. I hadn't tagged my resources
directory as containing resources in the IntelliJ project settings. Once I
did that it runs just fine. Thanks for pointing me to it, Kim!

- Dave

On Wed, Nov 26, 2014 at 3:09 PM, David Kincaid <kincaid.dave@gmail.com>
wrote:

> Thanks, Kim! That at least gives me somewhere to go. Hopefully it gets
> resolved soon.
>
> - Dave
>
> On Wed, Nov 26, 2014 at 3:06 PM, Kim Ebert <kim.ebert@imatsolutions.com>
> wrote:
>
>>  David,
>>
>> See the following ticket.
>>
>> https://issues.apache.org/jira/browse/CTAKES-307
>>
>>  Although, looking at the ticket itself seems to indicate that we only
>> fixed the build by extracting the contents of the jar file, and using that
>> in the classpath instead of the jar.
>>
>>
>>  [image: IMAT Solutions] <http://imatsolutions.com>
>>  Kim Ebert
>> Software Engineer
>> [image: Office:] 801.669.7342
>> kim.ebert@imatsolutions.com <greg.hubert@imatsolutions.com>
>>  On 11/26/2014 02:03 PM, Kim Ebert wrote:
>>
>> Hi David,
>>
>> I know that a few people have run into this issue. If it runs
>> successfully in one environment vs the other, you may want to check the
>> ordering of the libraries and resource directory in the classpath.
>>
>> This can be solved by using the resources outside of the jar file. I'm
>> hoping this issue ends up being resolved at some point. I believe Pei Chen
>> has made a few fixes, but I don't think that was in the 3.2.0 release.
>>
>> Thanks,
>>
>>  [image: IMAT Solutions] <http://imatsolutions.com>
>>  Kim Ebert
>> Software Engineer
>> [image: Office:] 801.669.7342
>> kim.ebert@imatsolutions.com <greg.hubert@imatsolutions.com>
>>  On 11/26/2014 01:31 PM, David Kincaid wrote:
>>
>> Does anyone know what is causing this exception:
>>
>>  java.lang.IllegalArgumentException: URI is not hierarchical
>>  at java.io.File.<init>(File.java:418)
>>  at
>> org.apache.ctakes.lvg.resource.LvgCmdApiResourceImpl.load(LvgCmdApiResourceImpl.java:65)
>>
>>  I'm getting that when I try to run the clinical pipeline inside of
>> IntelliJ using a TestNG unit test. I can run the pipeline from CPE and from
>> a Clojure REPL no problem, so it must be something in IntelliJ setting
>> something up wrong.
>>
>>  When I step through a debugger the uri it's trying to use is:
>>
>>
>> jar:file:/home/davek/.m2/repository/org/apache/ctakes/ctakes-lvg-res/3.2.0/ctakes-lvg-res-3.2.0.jar!/org/apache/ctakes/lvg/data/config/lvg.properties
>>
>>  which is clearly not a valid file path.
>>
>>  I came across Jira ticket CTAKES-314
>> <https://issues.apache.org/jira/browse/CTAKES-314> when it's mentioned
>> one time without any discussion. I haven't found any other references to it
>> yet though.
>>
>>  Thanks,
>>
>>  Dave
>>
>>
>>
>>
>

Mime
View raw message