ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pei Chen <pei.c...@wiredinformatics.com>
Subject Re: cTakes Document Preprocessor Component Error
Date Thu, 27 Nov 2014 04:29:24 GMT
Paula,
Which AggregateAE descriptor are you using?  If it includes:
https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-clinical-pipeline/desc/analysis_engine/SimpleSegmentAnnotator.xml

In particular, ensure that this is included:

    <typeSystemDescription>

      <imports>

        <import name="org.apache.ctakes.typesystem.types.TypeSystem"/>

      </imports>

    </typeSystemDescription>

If you plan to use uimaFIT, all you would need is to include the
ctakes-type-system project, it uses automatic type system detection  via:

https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-type-system/src/main/resources/META-INF/org.apache.uima.fit/types.txt

See example pipeline using uimaFIT:
https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-examples/src/main/java/org/apache/ctakes/examples/pipelines/ExampleAggregatePipeline.java


Hope that helps...

    Pei Chen
Wired Informatics <http://www.wiredinformatics.com>
265 Franklin St Ste 1702
Boston, MA 02110
tel: (617) 433-7544
Pei.Chen@wiredinformatics.com

On Wed, Nov 26, 2014 at 11:27 PM, Pei Chen <chenpei@apache.org> wrote:

>
> ---------- Forwarded message ----------
> From: digital paula <cybersation@hotmail.com>
> Date: Thu, Nov 14, 2013 at 2:41 PM
> Subject: cTakes Document Preprocessor Component Error
> To: "user@ctakes.apache.org" <user@ctakes.apache.org>
>
>
>   Hello cTakes Community,
>
> I'm back after hanging out with the UIMA guys :-) for a while, getting a
> better grasp of the UIMA framework that cTakes sits on.    I'm exploring
> and understanding cTakes components and starting with the Document
> Preprocessor:
>
> https://cwiki.apache.org/confluence/display/CTAKES/cTAKES+3.0+-+Document+Preprocessor
>
> I loaded the testpatient_cn_1.xml file in the CVD cTakes launcher and
> loaded the AggregateAE descriptor.   It loaded but when I ran it, I got the
> following error:
>
> Caused by: org.apache.uima.cas.CASRuntimeException: JCas type
> "org.apache.ctakes.typesystem.type.textspan.Segment" used in Java code, but
> was not declared in the XML type descriptor.
>
> I looked in the AggregatorAE descriptor file along with it's dependency CdaCasInitializer.xml
> and see both have nothing in the Type System tab however I do see a handful
> of types specified on the Capabilities tab including
> "org.apache.ctakes.typesystem.type.textspan.Segment"
>
> So I added Segment type to the Type System tab.  I reran and got this
> error:
>
> 11/14/13 2:23:39 PM - 14:
> org.apache.uima.tools.cvd.MainFrame.handleException(527): SEVERE: Feature
> "id" is not defined for type
> "org.apache.ctakes.typesystem.type.textspan.Segment".
> org.apache.uima.analysis_engine.AnalysisEngineProcessException: Feature
> "id" is not defined for type
> "org.apache.ctakes.typesystem.type.textspan.Segment".
> Is there a file descriptor already setup maybe in another install with the
> necessary types/features to run the Document Preprocessor or will I
> manually have to add all of them?   If not, I'd like to use UIMAfit to
> create the types/features to use with the Document Preprocessor as opposed
> to manually updating this descriptor with all the types and features
> needed.   Can someone advise?
>
> Thanks.
>
> Regards,
> Paula
>
>
>
>
>
>
>

Mime
View raw message