ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vijay garla <vnga...@gmail.com>
Subject Re: YTEX installation Exception java.lang.ExceptionInInitializerError
Date Tue, 25 Nov 2014 11:48:57 GMT
You will get a similarity of 0 if one of the concepts isn't in the concept
graph.  Did you test this via the web app / rest service / command line?

YTEX ships with the umls concept graph (all level 0 source vocabs + snomed
ct) and the sct-rxnorm concept graph (snomed-ct + rxnorm)

When I run the concept similarity service from the command line, I get
these results for umls concept graph:
Concept 1       Concept 2       LCH     INTRINSIC_LCH   lcs(s)  corpus lcs
intrinsic lcs   paths
C0042776        C0001175        0.682817        0.261689
 C1140093|C0000000               C1140093
 C1140093=C0042776->C0029235->*C1140093*<-C0001175<-C0039082<-C0012634|C0000000=C0042776->C0995203->*C0000000*<-C0001175<-C0039082<-C0679227

When I run with the sct-umls concept graph:
Concept 1       Concept 2       LCH     INTRINSIC_LCH   lcs(s)  corpus lcs
intrinsic lcs   paths
C0042776        C0001175        0.535563        0.267890        C0000000
      C0000000
 C0000000=C0042776->C0445623->C0029235->C2720507->*C0000000*<-C0001175<-C0729529<-C0153114

Here is my command:
java -cp %CLASSPATH%
-Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml -Xmx2g
 -Dytex.conceptGraphName=umls
org.apache.ctakes.ytex.kernel.metric.ConceptSimilarityServiceImpl -concepts
C0042776,C0001175 -lcs  -metrics LCH,INTRINSIC_LCH
or
java -cp %CLASSPATH%
-Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml -Xmx2g
 -Dytex.conceptGraphName=sct-umls
org.apache.ctakes.ytex.kernel.metric.ConceptSimilarityServiceImpl -concepts
C0042776,C0001175 -lcs  -metrics LCH,INTRINSIC_LCH

If you add the -lcs option you will get all the paths.

I think the high similarity you expect may not be modeled in the graph -
*AIDS* is a disease, *HIV* is-a *Virus* (that *causes AIDS*).  I'm not sure
if you can view *causes *as a hierarchical relationship.  If you want to,
you can create a concept graph that includes additional relationships (you
would have to check to see if this relationship is modeled in the UMLS).

HTH,

VJ



On Mon, Nov 24, 2014 at 7:55 PM, Giovanni Di Santo <giovi.disanto@gmail.com>
wrote:

> The installation procedure is over now and it seems it went well. If you
> need I can provide the installation logs.
> I have some questions about the semantic similarity feature. I have tried
> the example provided in the guide and It worked. I tried with other cui for
> example virus(C0042776) and aids(C0001175) and it gave me a similarity of
> 0.0... that sounded strange.
> I thought maybe because I was using a small part of umls so I tried with
> the option "-Dytex.conceptGraphName=umls" but I got the same result.
> Do I have to build my own concept graph and corups information content as
> described in the guide? if yes how can I do that for the whole umls
> database? Do you think the final graph would be too big?
>
> Best regards,
>
> Giovanni
>
> 2014-11-24 16:49 GMT+01:00 Giovanni Di Santo <giovi.disanto@gmail.com>:
>
>> Hi Vijay,
>> Thanks for your reply.
>> I added that file as you suggested. The installation process has passed
>> that point and now... I suppose... It's filling the database. I have been
>> running it for 2 hours so far... I suppose it's taking a lot of time cause
>> it's creating a dictionary lookup table for my local umls installation.
>> I'll let you know when the installation is over.
>>
>> Best regards
>>
>> Giovanni
>>
>> 2014-11-24 13:45 GMT+01:00 vijay garla <vngarla@gmail.com>:
>>
>>> Hi Giovanni,
>>>
>>> I think I found a bug in the offending class.  Can you copy the attached
>>> file to this directory:
>>>
>>> YTEX_HOME\resources\org\apache\ctakes\ytex\
>>>
>>> And retry?
>>>
>>> Thanks!
>>>
>>> VJ
>>>
>>>
>>> On Thu, Nov 20, 2014 at 4:16 PM, Giovanni Di Santo <
>>> giovi.disanto@gmail.com> wrote:
>>>
>>>> Hi,
>>>> I have tried to install YTEX in another machine and the same exception
>>>> is thrown during the installation. The output is slightly different:
>>>> http://pastebin.com/gVhSFYKp.
>>>> I suppose I make some mistakes during the installation process.
>>>> When in the ytes installation guide is written to copy  "over" my
>>>> installation I use a command like "cp -R /directory_fo_copy/* /ctakes_home".
>>>> Is there any already ready ytex version that I can download and use for
>>>> Linux?
>>>>
>>>> I don't really now what could be the problem and I need to test the
>>>> Semantic Similarity feature.
>>>>
>>>> Best regards
>>>>
>>>> Giovanni
>>>>
>>>> 2014-11-12 0:05 GMT+01:00 Kim Ebert <kim.ebert@perfectsearchcorp.com>:
>>>>
>>>>> Adding developer mailing list, as I'm not sure what is causing your
>>>>> error.
>>>>>
>>>>> Kim Ebert
>>>>> 1.801.669.7342
>>>>> Perfect Search Corp
>>>>> http://www.perfectsearchcorp.com/
>>>>>
>>>>> On 10/29/2014 11:57 AM, Giovanni Di Santo wrote:
>>>>> > Hi,
>>>>> > I'm trying to install ytex. I've followed the instructions provided
>>>>> > here
>>>>> > https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation
>>>>> > but the installing process stops and raises an Excpetion
>>>>> > java.lang.ExceptionInInitializerError.
>>>>> > More precisely I receive that output: http://pastebin.com/PrWyBxhx
.
>>>>> > I'm using cTakes 3.2 and the I've installed locally on a mysql db
the
>>>>> > umls 2014AA version.
>>>>> >
>>>>> > Best regards,
>>>>> >
>>>>> > Giovanni
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message