ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From britt fitch <britt.fi...@wiredinformatics.com>
Subject Re: cTakes Document Preprocessor Component Error
Date Wed, 26 Nov 2014 13:15:57 GMT
Hi Samir, it looks like you might have the wrong SVN client option specified. If I recall correctly,
in Windows it defaults to ‘JavaHL’ and you want to go to: 
‘Preferences' > ‘Team' > 'SVN' > 'SVN Client’ and select the ‘SVNKit’ option
from the drop down. 


 	 	 	 
Britt Fitch
Wired Informatics
265 Franklin St Ste 1702
Boston, MA 02110
http://wiredinformatics.com
Britt.Fitch@wiredinformatics.com

On Nov 26, 2014, at 1:24 AM, samir chabou <samirchb@yahoo.com> wrote:

> I'm trying to install cTAKES in eclipse but i got an error when i try a checkout as maven
project from SCM.
> the error is:
> <blob.jpeg>
> ',any help ?
> Thanks
> 
> 
> On Thursday, November 14, 2013 3:38 PM, "Masanz, James J." <Masanz.James@mayo.edu>
wrote:
> 
> 
> Try adding
> 
> org.apache.ctakes.typesystem.types.TypeSystem
> 
> as the type system.
> 
> So the source looks like:
> 
> <typeSystemDescription>
> <imports>
> <import name="org.apache.ctakes.typesystem.types.TypeSystem"/>
> </imports>
> </typeSystemDescription>
> 
> Hope that helps
> -- James
> 
> 
> From: user-return-336-Masanz.James=mayo.edu@ctakes.apache.org [mailto:user-return-336-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of digital paula
> Sent: Thursday, November 14, 2013 1:42 PM
> To: user@ctakes.apache.org
> Subject: cTakes Document Preprocessor Component Error
> 
> Hello cTakes Community,
>  
> I'm back after hanging out with the UIMA guys :-) for a while, getting a better grasp
of the UIMA framework that cTakes sits on.    I'm exploring and understanding cTakes components
and starting with the Document Preprocessor:
> https://cwiki.apache.org/confluence/display/CTAKES/cTAKES+3.0+-+Document+Preprocessor
>  
> I loaded the testpatient_cn_1.xml file in the CVD cTakes launcher and loaded the AggregateAE
descriptor.   It loaded but when I ran it, I got the following error:    
>  
> Caused by: org.apache.uima.cas.CASRuntimeException: JCas type "org.apache.ctakes.typesystem.type.textspan.Segment"
used in Java code, but was not declared in the XML type descriptor.
>  
> I looked in the AggregatorAE descriptor file along with it's dependency CdaCasInitializer.xml
and see both have nothing in the Type System tab however I do see a handful of types specified
on the Capabilities tab including "org.apache.ctakes.typesystem.type.textspan.Segment"
>  
> So I added Segment type to the Type System tab.  I reran and got this error:
> 
> 11/14/13 2:23:39 PM - 14: org.apache.uima.tools.cvd.MainFrame.handleException(527): SEVERE:
Feature "id" is not defined for type "org.apache.ctakes.typesystem.type.textspan.Segment".
> org.apache.uima.analysis_engine.AnalysisEngineProcessException: Feature "id" is not defined
for type "org.apache.ctakes.typesystem.type.textspan.Segment".
> Is there a file descriptor already setup maybe in another install with the necessary
types/features to run the Document Preprocessor or will I manually have to add all of them?
  If not, I'd like to use UIMAfit to create the types/features to use with the Document Preprocessor
as opposed to manually updating this descriptor with all the types and features needed.  
Can someone advise?  
>  
> Thanks.
>  
> Regards,
> Paula
>  
>  
> 
>  
>  
> 
> 
> <blob.jpeg>


Mime
View raw message