ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kincaid <kincaid.d...@gmail.com>
Subject Re: NPE with ytex in ctakes 3.2.0
Date Tue, 14 Oct 2014 13:59:25 GMT
Yes. I did do that. I just redid that step again to be sure and am still
getting the same error.

On Tue, Oct 14, 2014 at 8:50 AM, vijay garla <vngarla@gmail.com> wrote:

> Hi Dave,
>
> I uploaded scripts to the wiki page (step 1.5) - that issue should be
> ironed out with the updated scripts - did you unpack them?
>
> -vj
>
> On Tue, Oct 14, 2014 at 3:43 PM, David Kincaid <kincaid.dave@gmail.com>
> wrote:
>
>> Thanks. I'm getting an error on step 7 (Execute the setup script). When I
>> try to run it using the command line given I get the following:
>>
>> [~/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts]> nohup ../../ant -f
>> build-setup.xml -Dlog4j.conf=CTAKES_HOME/config/log4j.xml all > setup.out
>> 2>&1 &
>> [1] 8129
>> [~/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts]> tail -f setup.out
>> nohup: ignoring input
>> Error: Could not find or load main class org.apache.tools.ant.Main
>>
>> So, I tried to run it using my already installed version of ant and get
>> this different error:
>>
>> [~/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts]> nohup ant -f
>> build-setup.xml -Dlog4j.conf=CTAKES_HOME/config/log4j.xml all > setup.out
>> 2>&1 &
>> [1] 8178
>> [~/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts]> tail -f setup.out
>> nohup: ignoring input
>> Buildfile:
>> /home/davek/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts/build-setup.xml
>>
>> BUILD FAILED
>> /home/davek/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts/build-setup.xml:44:
>> The following error occurred while executing this line:
>> /home/davek/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts/build-classpath.xml:109:
>> A source file is missing:
>> /home/davek/apps/apache-ctakes-3.2.0/bin/ctakes-ytex/scripts/CTAKES_HOME/config/log4j.xml
>>
>> that second one looks like a typo in the build.xml, but since I'm not too
>> familiar with ant scripts I can't spot where it is.
>>
>> On Tue, Oct 14, 2014 at 8:07 AM, vijay garla <vngarla@gmail.com> wrote:
>>
>>> OK, updated the ytex install page:
>>> https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation
>>>
>>>
>>> On Tue, Oct 14, 2014 at 2:54 PM, vijay garla <vngarla@gmail.com> wrote:
>>>
>>>> Hi Dave,
>>>>
>>>> Let me update the instructions first - I'll tell you when I'm done.
>>>>
>>>> -vj
>>>>
>>>> On Tue, Oct 14, 2014 at 2:46 PM, David Kincaid <kincaid.dave@gmail.com>
>>>> wrote:
>>>>
>>>>> Thanks, Vijay. I'm running from the ctakes distro. I'll run through
>>>>> the steps in the link you included.
>>>>>
>>>>> - Dave
>>>>>
>>>>> On Tue, Oct 14, 2014 at 3:25 AM, vijay garla <vngarla@gmail.com>
>>>>> wrote:
>>>>>
>>>>>> The error is caused by not finding the required properties files/xml
>>>>>> config files.
>>>>>> There are some issues with the ytex setup scripts for the 3.2
>>>>>> release; I have fixed that in trunk.  I am updating the 3.2 installation
>>>>>> guide with the patched setup scripts.
>>>>>>
>>>>>> It's not clear to me if you're running from a dev
>>>>>> environment/eclipse, or running from the ctakes distro.
>>>>>> If running from a development environment, see
>>>>>> https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-ytex/README
>>>>>> If running from the ctakes distro, make sure you follow the ytex
>>>>>> setup:
>>>>>> https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation
>>>>>>
>>>>>> For the dev environment, the xml config file is in the
>>>>>> ctakes-ytex-res (
>>>>>> https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-ytex-res/src/main/resources/org/apache/ctakes/ytex/uima/beanRefContext.xml
>>>>>> )
>>>>>> For the binary distro, the xml config files are in
>>>>>> lib\ctakes-ytex-res-3.2.0.jar
>>>>>>
>>>>>>
>>>>>> -vj
>>>>>>
>>>>>>
>>>>>> On Fri, Oct 10, 2014 at 10:56 PM, David Kincaid <
>>>>>> kincaid.dave@gmail.com> wrote:
>>>>>>
>>>>>>> I don't have that file anywhere either. Where do I get it from?
>>>>>>>
>>>>>>> On Fri, Oct 10, 2014 at 3:53 PM, Chen, Pei <
>>>>>>> Pei.Chen@childrens.harvard.edu>
>>>>>>> wrote:
>>>>>>>
>>>>>>> > I think it’s in ctakes-ytex-res.jar (is that in your classpath)?
>>>>>>> > This is just a guess… vj may have a better idea if it
still
>>>>>>> doesn’t work
>>>>>>> > for you.
>>>>>>> >
>>>>>>> > From: David Kincaid [mailto:kincaid.dave@gmail.com]
>>>>>>> > Sent: Friday, October 10, 2014 4:51 PM
>>>>>>> > To: user@ctakes.apache.org
>>>>>>> > Subject: Re: NPE with ytex in ctakes 3.2.0
>>>>>>> >
>>>>>>> > No. I have no file named beanRefContext.xml anywhere on
my hard
>>>>>>> drive.
>>>>>>> >
>>>>>>> >
>>>>>>> >
>>>>>>> > On Fri, Oct 10, 2014 at 3:45 PM, Chen, Pei <
>>>>>>> Pei.Chen@childrens.harvard.edu
>>>>>>> > <mailto:Pei.Chen@childrens.harvard.edu>> wrote:
>>>>>>> > I’m not too familiar with the ytex component,
>>>>>>> > but my guess is that the ytexApplicationContext bean is
null?
>>>>>>> > It seems that it would be expected to be in the
>>>>>>> > classpath*:org/apache/ctakes/ytex/uima/beanRefContext.xml?
 Do
>>>>>>> those exists?
>>>>>>> >
>>>>>>> > From: David Kincaid [mailto:kincaid.dave@gmail.com<mailto:
>>>>>>> > kincaid.dave@gmail.com>]
>>>>>>> > Sent: Friday, October 10, 2014 4:23 PM
>>>>>>> > To: user@ctakes.apache.org<mailto:user@ctakes.apache.org>
>>>>>>> > Subject: NPE with ytex in ctakes 3.2.0
>>>>>>> >
>>>>>>> > I'm trying to experiment the ytex in 3.2.0. Trying to run
>>>>>>> > AggregatePlaintextUMLSProcessor with the
>>>>>>> FilesInDirectoryCollectionReader
>>>>>>> > and FileWriterCASConsumer. When I try to run it against
some text
>>>>>>> files it
>>>>>>> > blows up with a null pointer exception during initialization.
>>>>>>> Here's the
>>>>>>> > relevant part of the stack trace. Anyone have any ideas
what I
>>>>>>> might have
>>>>>>> > wrong?:
>>>>>>> >
>>>>>>> > Caused by:
>>>>>>> org.apache.uima.resource.ResourceInitializationException:
>>>>>>> > Initialization of annotator class
>>>>>>> > "org.apache.ctakes.ytex.uima.annotators.SegmentRegexAnnotator"
>>>>>>> failed.
>>>>>>> > (Descriptor:
>>>>>>> >
>>>>>>> file:/home/davek/apps/apache-ctakes-3.2.0/desc/ctakes-ytex-uima/desc/analysis_engine/SegmentRegexAnnotator.xml)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.PrimitiveAnalysisEngine_impl.initializeAnalysisComponent(PrimitiveAnalysisEngine_impl.java:252)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.PrimitiveAnalysisEngine_impl.initialize(PrimitiveAnalysisEngine_impl.java:156)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.impl.AnalysisEngineFactory_impl.produceResource(AnalysisEngineFactory_impl.java:94)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.impl.CompositeResourceFactory_impl.produceResource(CompositeResourceFactory_impl.java:62)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.UIMAFramework.produceResource(UIMAFramework.java:269)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.UIMAFramework.produceAnalysisEngine(UIMAFramework.java:387)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.asb.impl.ASB_impl.setup(ASB_impl.java:254)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.AggregateAnalysisEngine_impl.initASB(AggregateAnalysisEngine_impl.java:431)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.AggregateAnalysisEngine_impl.initializeAggregateAnalysisEngine(AggregateAnalysisEngine_impl.java:375)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.AggregateAnalysisEngine_impl.initialize(AggregateAnalysisEngine_impl.java:185)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.impl.AnalysisEngineFactory_impl.produceResource(AnalysisEngineFactory_impl.java:94)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.impl.CompositeResourceFactory_impl.produceResource(CompositeResourceFactory_impl.java:62)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.UIMAFramework.produceResource(UIMAFramework.java:269)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.UIMAFramework.produceResource(UIMAFramework.java:314)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.UIMAFramework.produceAnalysisEngine(UIMAFramework.java:425)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.collection.impl.cpm.container.CPEFactory.produceIntegratedCasProcessor(CPEFactory.java:1088)
>>>>>>> >           ... 9 more
>>>>>>> > Caused by: java.lang.NullPointerException
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.ctakes.ytex.uima.ApplicationContextHolder.getApplicationContext(ApplicationContextHolder.java:79)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.ctakes.ytex.uima.annotators.SegmentRegexAnnotator.initialize(SegmentRegexAnnotator.java:64)
>>>>>>> >           at
>>>>>>> >
>>>>>>> org.apache.uima.analysis_engine.impl.PrimitiveAnalysisEngine_impl.initializeAnalysisComponent(PrimitiveAnalysisEngine_impl.java:250)
>>>>>>> >           ... 24 more
>>>>>>> >
>>>>>>> >
>>>>>>> >
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message