ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim O'Connell" <tim.oconn...@gmail.com>
Subject Re: Cannot load AggregatePlainTextUmlsProcessor.xml
Date Thu, 14 Aug 2014 15:54:37 GMT
Hi folks,

Just a quick question/some more info about this issue from last month's
thread.  I'm having the same issue.  I've been able to characterize it
somewhat.

- If I run the ytex setup script with umls.schema commented out in
ytex.properties, then it takes about 4 minutes to run and ytex 'works' - in
CVD, I can use AggregatePlainTextUmlsProcessor and it will pick up the
annotations, but the error 'ERROR [SqlExceptionHelper] Table 'ytex.mrsty'
doesn't exist' shows up in the log files, and while ytex does find entities
in the reports, it doesn't categorize them (e.g. as events/DiseaseDisorder
etc).  It seems to me that this is a UMLS table, not a ytex table, so
something here isn't making sense.
- If I run the setup script with umls.schema=umls, then it takes about 3
hours to run, but ytex doesn't 'work' - i.e. it doesn't pick up on any
annotations in the text in CVD.
- I also noticed the documentation states that umls.catalog should be set
in ytex.properties, but it doesn't appear in the ytex.properties templates.
 I've tried setting it to umls.catalog=umls but it doesn't seem to make any
difference.

- As for the issues with the SQL error reported by the other users, it
doesn't make any difference if I replace @db.schema@ with ytex - all this
does is return the same error saying it can't find the schema YTEX.
- I've tried changing AggregatePlainTextUmlsProcessor.xml  to use the
ctakes dictionary lookup, but this just fails and says to check the log
file, but no errors show up in the log file.

After all this, I get the impression that maybe I've completely missed a
step in the setup because it looks like some major linkage(s) is/are
missing.  Any thoughts?

Tim

Mime
View raw message