ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject Re: UMLS integration with cTAKES 3.1​
Date Fri, 25 Jul 2014 18:06:25 GMT
Did you also try lower case in the table name?

Sent from my iPhone

On Jul 25, 2014, at 2:02 PM, "Natalia Connolly" <natalia.v.connolly@gmail.com<mailto:natalia.v.connolly@gmail.com>>
wrote:

Yes:


mysql> use umls;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> show tables;
+-----------------+
| Tables_in_umls  |
+-----------------+
| AMBIGLUI        |
| AMBIGSUI        |
| DELETEDCUI      |
| DELETEDLUI      |
…….

| umls_ms_2013    |
| umls_snomed_map |
+-----------------+
49 rows in set (0.00 sec)

   Natalia




On Fri, Jul 25, 2014 at 1:59 PM, Chen, Pei <Pei.Chen@childrens.harvard.edu<mailto:Pei.Chen@childrens.harvard.edu>>
wrote:
That is odd.  Nothing seems out of the ordinary…
And the database name is umls?
jdbc:mysql://localhost:3306/umls

From: Natalia Connolly [mailto:natalia.v.connolly@gmail.com<mailto:natalia.v.connolly@gmail.com>]
Sent: Friday, July 25, 2014 1:54 PM
To: user@ctakes.apache.org<mailto:user@ctakes.apache.org>

Subject: Re: Fwd: UMLS integration with cTAKES 3.1​

Hi Pei,

    I can't see any issues with LookupDesc_Db, so I am attaching both it and  DictionaryLookupAnnotatorDB.xml.
 I only modified the username/password in the second file to "myusername" and "mypassword"
for security purposes.  They were correct before, I checked it many times.

    Thank you so much for your help,

    Natalia


On Fri, Jul 25, 2014 at 1:34 PM, Chen, Pei <Pei.Chen@childrens.harvard.edu<mailto:Pei.Chen@childrens.harvard.edu>>
wrote:
Natalia,
That is strange.  It sounds like it isn't configured to use the right resource.
Could you double check the mappings, in particular: in your LookupDesc_Db.xml:
externalResourceKey="DbConnection" to ensure it's using the right resource that was added
in your DictionaryLookupAnnotatorDB.xml?
If it still doesn't work, would you mind attaching the xml config files?

--Pei

> -----Original Message-----
> From: John Green [mailto:john.travis.green@gmail.com<mailto:john.travis.green@gmail.com>]
> Sent: Friday, July 25, 2014 1:06 PM
> To: user@ctakes.apache.org<mailto:user@ctakes.apache.org>; dev@ctakes.apache.org<mailto:dev@ctakes.apache.org>
> Subject: Re: Fwd: UMLS integration with cTAKES 3.1​
>
> This sounds just like jira ctakes-306.
>
>
> JG
> —
>
> On Fri, Jul 25, 2014 at 1:04 PM, John Green <hephaestus.studio@gmail.com<mailto:hephaestus.studio@gmail.com>>
> wrote:
>
> > —
> > ---------- Forwarded message ----------
> > From: "Natalia Connolly" <natalia.v.connolly@gmail.com<mailto:natalia.v.connolly@gmail.com>>
> > Date: Fri, Jul 25, 2014 at 12:35 PM
> > Subject: UMLS integration with cTAKES 3.1
> > To: "user@ctakes.apache.org<mailto:user@ctakes.apache.org>" <user@ctakes.apache.org<mailto:user@ctakes.apache.org>>
> >> Hello,
> >>    I am trying to supplement the basic cTAKES dictionary with the
> >> latest UMLS release.  Following the instructions here (
> >> https://cabig-
> kc.nci.nih.gov/Vocab/forums/viewtopic.php?f=28&t=80#p25<http://kc.nci.nih.gov/Vocab/forums/viewtopic.php?f=28&t=80#p25>
> >> 8), I built a mysql database and imported UMLS data into it as two tables,
> >> umls_ms_2013 and umls_snomed_map.     I then modified
> >> DictionaryLookupAnnotatorDB.xml as follows:
> >> <name>URL</name>
> >>    <value>
> >>       <string>jdbc:mysql://localhost:3306/umls</string>
> >>   </value>
> >>    and I also changed LookupDesc_Db.xml to reflect my two table names.
> >>    After I added DictionaryLookupAnnotatorDB.xml to my analysis
> >> engines in runctakesCPE.sh, I got the following error:
> >> org.apache.uima.analysis_engine.AnalysisEngineProcessException
> CausedBY:
> >> org.apache.ctakes.dictionary.lookup.DictionaryException:
> >> java.sql.SQLException: Table not found in statement [SELECT tui,
> >> text, cui from UMLS_MS_2013 where fword =?]
> >>      This is strange because the table does exist and it's not empty:
> >> mysql> SELECT tui, text, cui from UMLS_MS_2013 limit 2;
> >> +------+--------+----------+
> >> | tui  | text   | cui      |
> >> +------+--------+----------+
> >> | T121 | MSH    | C0000005 |
> >> | T121 | MSHFRE | C0000005 |
> >> +------+--------+----------+
> >> 2 rows in set (0.00 sec)
> >>      Can someone please help?
> >>      Thank you,
> >>      Natalia Connolly


Mime
View raw message