ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lee, Richard A. [USA]" <lee_rich...@bah.com>
Subject RE: Re: ctakes 3.1.2 produces no medical annotations for me
Date Tue, 03 Jun 2014 20:27:04 GMT
Ok, so I went ahead and re-ran mmsys. Trying to use the previously-used mmsys kept getting
me Null Pointer Exceptions, so I downloaded a fresh copy and used that. When running its run64.bat,
I stuck to the defaults except for setting the UMLS destination directory (kept it separate
from the one produced by mmsys before) and changing the subset selection to include SNOMED-CT.

When I compare the mmsys.log entries between the 2 runs, I see only the modest differences
you would expect from the fact that they used different data sets (2014AA vs 2013AB).

When I run the new mmsys’ run64.bat and selected “browse subset”, the resulting tree
browser list included “(SNOMEDCT_US) SNOMED CT Concept”. When I did the same for the old
mmsys, I had to point it at the DB to get an index, and then I also see SNOMEDCT_US listed.

So that and the log diffs lead me to suspect lacking SNOMED CT is not my problem…

Help?

From: Lee, Richard A. [USA] [mailto:lee_richard@bah.com]
Sent: Fri, 23 May, 2014 20:38
To: user@ctakes.apache.org
Subject: RE: Re: ctakes 3.1.2 produces no medical annotations for me

Vijay, thanks.
I get a run-time exception when trying to use the stock AE in 3.1.2. (In fact, it was the
same one I’d reported to you (and reported here on Mon) before you advised me I’d failed
to unzip a collection of jar files into lib.) As noted, the log file ends with no signs of
distress, but does report “DEBUG [DataBinder] DataBinder requires binding of required fields
[]” several times earlier.
I went through the MetamorphoSys DB-setup process two months ago, so I cannot remember for
sure whether I included SNOMED-CT or not. I don’t see “SNOMED-CT” per se in mmsys.log;
is there something else I should look for there, or an easy check in the DB itself?

From: vijay garla [mailto:vngarla@gmail.com]
Sent: Fri, 23 May, 2014 20:08
To: user@ctakes.apache.org<mailto:user@ctakes.apache.org>
Subject: [External] Re: ctakes 3.1.2 produces no medical annotations for me

Hi Richard,

Did you add SNOMED-CT when creating your UMLS Subset?  The dictionary that YTEX ships with
has ~1.5 million entries.  If that doesn't work, you can also try running the stock cTAKES
AggregatePlaintextUMLSProcessor to see if that creates different annotations.

HTH,

-vj

On Fri, May 23, 2014 at 4:58 PM, Lee, Richard A. [USA] <lee_richard@bah.com<mailto:lee_richard@bah.com>>
wrote:
Hi, folks.

I’ve been trying to use the new cTAKES 3.1.2 with ytex, using the AggregatePlaintextUMLSProcessor.xml
AE under ctakes-ytex-uima, and so far it’s not been producing the numerous medical annotations
(eg DiseaseDisorderMention) that I was getting on the same documents with cTAKES 3.1.1. Attached
screenshot will hopefully make this clear.

I did use MetamorphoSys to set up the UMLS tables, and then the ytex script to populate its
schema, and I now have ytex tables with hundreds of thousands of entries.

I’ve upped the logging level in the hopes the log file would provide a clue, and the only
thing I’m seeing is a lot of “DEBUG [FirstTokenPermutationImpl] Window size of 8 exceeds
the max permutation level of 7.”; that number varies from 8 to 12.

Would that explain the problem? If so, how do I fix it? If not, how do I find the problem?
Thanks.



Mime
View raw message