ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vijay garla <vnga...@gmail.com>
Subject Re: [External] Re: Cannot load AggregatePlainTextUmlsProcessor.xml
Date Wed, 18 Jun 2014 14:11:55 GMT
The YTEX AggregatePlaintextUMLSProcessor differs from the default
AggregatePlaintextUMLSProcessor in the following a ways:
* Use SegmentRegexAnnotator instead of SimpleSegmentAnnotator
* Use SentenceDetectorAnnotator without splitting on newlines
* Added SenseDisambiguatorAnnotator
** Use YTEX DictionaryLookupAnnotatorDB instead of cTAKES
DictionaryLookupAnnotatorDB*

The YTEX dictionary lookup is different from cTAKES':
* uses the old dictionary lookup
* uses a single dictionary
* uses a single lookup consumer that creates plain-vanilla EntityMention
annotations (none of the subtypes)

I think that if you change the YTEX AggregatePlaintextUMLSProcessor to
point at the cTAKES dictionary lookup, you will get approximately same
annotations (probably more if sentences do not end on newlines, as
dictionary lookup is not performed across sentences)

could you try the following please:
In
desc\ctakes-ytex-uima\desc\analysis_engine\AggregatePlaintextUMLSProcessor.xml
change
<delegateAnalysisEngine key="DictionaryLookupAnnotatorDB">
<import location="./DictionaryLookupAnnotator.xml" />
</delegateAnalysisEngine>
To
    <delegateAnalysisEngine key="DictionaryLookupAnnotatorDB">
      <import
location="../../../ctakes-dictionary-lookup/desc/analysis_engine/DictionaryLookupAnnotatorUMLS.xml"/>
    </delegateAnalysisEngine>

And re-run.  You should get the same results (keep in mind the newline
thing).





On Wed, Jun 18, 2014 at 9:46 AM, Lee, Richard A. [USA] <lee_richard@bah.com>
wrote:

>  Yes, that exactly the problem I’ve been reporting. I think you’ll see
> that it you still get the non-Medical annotations, like Date, RomanNumeral,
> et al, but not DiseaseDisorderMention and the other Medical ones, right?
>
>
>
> I’m still hoping someone can assist with this.
>
>
>
> *From:* Abhishek Raj [mailto:abhishekrm@iitrpr.ac.in]
> *Sent:* Wed, 18 Jun, 2014 04:43
> *To:* user@ctakes.apache.org
> *Subject:* Re: [External] Re: Cannot load
> AggregatePlainTextUmlsProcessor.xml
>
>
>
> Found a fix. Will post it here in case it helps someone. When using
> ctakes-3.1.2, load the AggregatePlainTextUmlsProcessor.xml from "
> CTAKES_HOME/desc/ytex-uima/desc/analysis_engine/
> AggregatePlaintextUMLSProcessor.xml" and not from the usual "
> CTAKES_HOME/desc/ctakes-clinical-pipeline/desc/analysis_engine/
> AggregatePlaintextUMLSProcessor.xml" as given here
> <https://cwiki.apache.org/confluence/display/CTAKES/User%27s+Guide>.
>
> However strangely, "ytex-uima/desc/analysis_engine/AggregatePlaintextUMLSProcessor.xml"
> produced even less annotations than "
> ctakes-clinical-pipeline/desc/analysis_engine/
> AggregatePlaintextUMLSProcessor.xml".
>
> I expected ytex-specific AE to produce better results. But clearly that's
> not the case.
>
>
>
> On Thu, Jun 12, 2014 at 2:51 AM, Abhishek Raj <abhishekrm@iitrpr.ac.in>
> wrote:
>
> Hi. Thanks for the reply.
> I have a file named LookupDesc_Db.xml which has the line <jdbcImpl
> tableName="@db.schema@.v_snomed_fword_lookup"/>
>
> instead of LookupDesc_SNOMED.*template*.xml. Also, my ytex.properties
> file seems fine. I have attached the file for your reference.
> And yes, when running the ant setup by following #7 on this
> <https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation> link,
> it sends the output to "setup.out". The build was successful though. I
> didn't see any errors. I am attaching the file for your reference as well.
> Please have a look and let me know.
>
>
>

Mime
View raw message