ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramprasad Reddy <ramprasadredd...@gmail.com>
Subject RE: Error while processing few Medical records using CPE
Date Tue, 13 May 2014 18:50:09 GMT
Hi Pei Chen,

I am using plain text files as source. But I noticed, it has some special
characters. I will try removing them and retry the process.

Thank you for your quick response.

RP
On May 13, 2014 1:46 PM, "Chen, Pei" <Pei.Chen@childrens.harvard.edu> wrote:

> RP,
> From the exception, could you check to see if there were some special/non
> xml chars in the source documents?
> I assume you were using the default XML/XMI Writer to write the output as
> XML…
>
> 1) Can change the specials chars.  This of course would depend on your
> application needs.
> 2) Save the output in some char sequence or other alternative
> serialization method.
>
> There might be some useful utils from the UIMA package itself:
> org.apache.uima.internal.util.XMLUtils
>
> From: Ramprasad Reddy [mailto:ramprasadreddy.a@gmail.com]
> Sent: Tuesday, May 13, 2014 11:55 AM
> To: user@ctakes.apache.org
> Subject: Error while processing few Medical records using CPE
>
> Hi,
> I have been trying to run CPE using AggregatePlainTextUMLSProcessor.xml
> engine against few medical records. I am getting the following error
> "org.apache.uima.analysis_engine.AnalysisEngineProcessException
>  CausedBy: org.apache.uima.resource.ResourceProcessException
>  CausedBy: org.xml.sax.SAXParseException; Trying to serialize non-XML 1.0
> character: ,0xb"
>
> I am running the engine using the default settings only. Few medical
> records are able to run successfully, but after it is stopping giving the
> above error.
> Has anyone also faced this issue and identified a solution?
> Thank you,
> Ramprasad(RP).
>

Mime
View raw message