ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karthik Sarma <ksa...@ksarma.com>
Subject Re: Adding UMLS username and password ....
Date Tue, 24 Dec 2013 05:22:20 GMT
Hmm looks like there actually might be a typo in the descriptor -- it had
to be modified to set for UMLS. Check the aggregate processor xml file for
the typo





--
Karthik Sarma
UCLA Medical Scientist Training Program Class of 20??
Member, UCLA Medical Imaging & Informatics Lab
Member, CA Delegation to the House of Delegates of the American Medical
Association
ksarma@ksarma.com
gchat: ksarma@gmail.com
linkedin: www.linkedin.com/in/ksarma


On Mon, Dec 23, 2013 at 10:28 PM, Pei Chen <chenpei@apache.org> wrote:

> not sure if it's a email copy and paste error or is it just a typo:
> DcitionaryLookupAnnotatorUMLS.xml
> instead ??? DictionaryLookupAnnotatorUMLS.xml  ???
> Would you be able to go to View > Log > there's usually a bit more info in
> the ~/uima.log file.
>
>
> On Mon, Dec 23, 2013 at 11:21 PM, Joshua Weiner <joshuaweiner2@gmail.com>wrote:
>
>> I changed my password so it no loner has a %... and I also set the
>> password in the dictionarylookupannotatorUMLS.xml file as you described...
>>
>> I still get the same error...
>> org.apache.uima.resource.ResourceInitializationException: Initialization
>> of annotator class
>> "org.apache.ctakes.dictionary.lookup.ae.UmlsDictionaryLookupAnnotator"
>> failed. (Descriptor:
>> file:/C:/apache-ctakes-3.1.0/desc/ctakes-dictionary-lookup/desc/analysis_engine/DcitionaryLookupAnnotatorUMLS.xml)
>> ...
>>
>> What is going on???
>>
>>
>> On Mon, Dec 23, 2013 at 10:49 PM, Pei Chen <chenpei@apache.org> wrote:
>>
>>> Hi Joshua,
>>> I just noticed that you figured out the escaping issue.  But based on
>>> the error, it probably still failed due to invalid umls pw (if you check
>>> the uima.log files you will probably see the out put.)
>>> If you want to bypass the entire escaping the environment var issue, you
>>> can also set the umls credentials within the xml file itself:
>>> Which should be inside your:
>>> C:/apache-ctakes-3.1.0/desc/ctakes-dictionary-lookup/
>>> desc/analysis_engine/DcitionaryLookupAnnotatorUMLS.xml
>>>
>>>
>>> On Mon, Dec 23, 2013 at 10:26 PM, Joshua Weiner <joshuaweiner2@gmail.com
>>> > wrote:
>>>
>>>> Gah .. I am not sure why this is so challenging... Now I try to run;
>>>> AggregatePlaintextUMLSProcessor.xml
>>>>
>>>> and I get the error:
>>>> org.apache.uima.resource.ResourceInitializationException:
>>>> Initialization of annotator class
>>>> "org.apache.ctakes.dictionary.lookup.ae.UmlsDictionaryLookupAnnotator"
>>>> failed. (Descriptor:
>>>> file:/C:/apache-ctakes-3.1.0/desc/ctakes-dictionary-lookup/desc/analysis_engine/DcitionaryLookupAnnotatorUMLS.xml)
>>>> ...
>>>>
>>>> hopefully this is my last problem!! Thank you for your help.!!!!!!!!!!!
>>>>
>>>> Josh
>>>>
>>>>
>>>> On Mon, Dec 23, 2013 at 10:21 PM, Joshua Weiner <
>>>> joshuaweiner2@gmail.com> wrote:
>>>>
>>>>> Smart man karthik. I do have a percent sign in my password. Thank you
>>>>> for your help here, both of you.
>>>>>
>>>>> Works now! Great tip.
>>>>> On Dec 23, 2013 7:11 PM, "Karthik Sarma" <ksarma@ksarma.com> wrote:
>>>>>
>>>>>> Ah, I think I might know the problem. You probably have a percent
>>>>>> sign in your password. If so, you should replace it with a double
percent
>>>>>> (%%) in the batch file, as the % sign is a reserved character in
batch
>>>>>> files.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Karthik Sarma
>>>>>> UCLA Medical Scientist Training Program Class of 20??
>>>>>> Member, UCLA Medical Imaging & Informatics Lab
>>>>>> Member, CA Delegation to the House of Delegates of the American
>>>>>> Medical Association
>>>>>> ksarma@ksarma.com
>>>>>> gchat: ksarma@gmail.com
>>>>>> linkedin: www.linkedin.com/in/ksarma
>>>>>>
>>>>>>
>>>>>> On Mon, Dec 23, 2013 at 9:05 PM, Joshua Weiner <
>>>>>> joshuaweiner2@gmail.com> wrote:
>>>>>>
>>>>>>> when I run the script I get the following error: ((see below
the
>>>>>>>
>>>>>>>
>>>>>>> I run: bin\runctakesCVD.bat
>>>>>>> I get:
>>>>>>>
>>>>>>> C:\apache-ctakes-3.1.00>java -Dctakes.umlsuser=joshuawiener2
>>>>>>> -Dctakes.umlspw=mypasswordCTAKES_HOMECTAKES_HOMECTAKES_HOME/C:\apache-ctakes-3.1.0/config/log4j.xml
>>>>>>> -Xms512M -Xmx2048M org.apache.uima.tools.cvd.CVD
>>>>>>>  Error: Could not find or load main class
>>>>>>> org.apache.uima.tools.cvd.CVD
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Mon, Dec 23, 2013 at 10:02 PM, Karthik Sarma <ksarma@ksarma.com>wrote:
>>>>>>>
>>>>>>>> OK, and what is the output when you run the script?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> Karthik Sarma
>>>>>>>> UCLA Medical Scientist Training Program Class of 20??
>>>>>>>> Member, UCLA Medical Imaging & Informatics Lab
>>>>>>>> Member, CA Delegation to the House of Delegates of the American
>>>>>>>> Medical Association
>>>>>>>> ksarma@ksarma.com
>>>>>>>> gchat: ksarma@gmail.com
>>>>>>>> linkedin: www.linkedin.com/in/ksarma
>>>>>>>>
>>>>>>>>
>>>>>>>> On Mon, Dec 23, 2013 at 8:59 PM, Joshua Weiner <
>>>>>>>> joshuaweiner2@gmail.com> wrote:
>>>>>>>>
>>>>>>>>> based on the code below I see the home directory as being
set to
>>>>>>>>> the current_dir which is C:\apache-ctakes-3.0.1..............
>>>>>>>>>
>>>>>>>>> I also tried using James code to re-set the directory
.. did not
>>>>>>>>> work.
>>>>>>>>>
>>>>>>>>> @REM Guess CTAKES_HOME if not defined
>>>>>>>>> set CURRENT_DIR=%cd%
>>>>>>>>> if not "%CTAKES_HOME%" == "" goto gotHome
>>>>>>>>> set CTAKES_HOME=%CURRENT_DIR%
>>>>>>>>> if exist "%CTAKES_HOME%\bin\runctakesCVD.bat" goto okHome
>>>>>>>>> cd ..
>>>>>>>>> set CTAKES_HOME=%cd%
>>>>>>>>>
>>>>>>>>> :gotHome
>>>>>>>>> if exist "%CTAKES_HOME%\bin\runctakesCVD.bat" goto okHome
>>>>>>>>> echo The CTAKES_HOME environment variable is not defined
correctly
>>>>>>>>> echo This environment variable is needed to run this
program
>>>>>>>>> goto end
>>>>>>>>>
>>>>>>>>> :okHome
>>>>>>>>> cd %CTAKES_HOME%
>>>>>>>>> java -Dctakes.umlsuser=joshuawiener2 -Dctakes.umlspw=56Kmartin%
>>>>>>>>> -cp "%CTAKES_HOME%/lib/*;%CTAKES_HOME%/desc/;%CTAKES_HOME%/resources/"
>>>>>>>>> -Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml
-Xms512M
>>>>>>>>> -Xmx2048M org.apache.uima.tools.cvd.CVD
>>>>>>>>>
>>>>>>>>> :end
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Mon, Dec 23, 2013 at 9:55 PM, Karthik Sarma <ksarma@ksarma.com>wrote:
>>>>>>>>>
>>>>>>>>>> What is your CTAKES_HOME set to?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> --
>>>>>>>>>> Karthik Sarma
>>>>>>>>>> UCLA Medical Scientist Training Program Class of
20??
>>>>>>>>>> Member, UCLA Medical Imaging & Informatics Lab
>>>>>>>>>> Member, CA Delegation to the House of Delegates of
the American
>>>>>>>>>> Medical Association
>>>>>>>>>> ksarma@ksarma.com
>>>>>>>>>> gchat: ksarma@gmail.com
>>>>>>>>>> linkedin: www.linkedin.com/in/ksarma
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Mon, Dec 23, 2013 at 8:50 PM, Joshua Weiner <
>>>>>>>>>> joshuaweiner2@gmail.com> wrote:
>>>>>>>>>>
>>>>>>>>>>> Where do you see this James?
>>>>>>>>>>>
>>>>>>>>>>> Here is my code... I see the -cp parameter and
its arguements
>>>>>>>>>>> right after "mypassword" ... right?
>>>>>>>>>>>
>>>>>>>>>>> :okHome
>>>>>>>>>>> cd %CTAKES_HOME%
>>>>>>>>>>> java -Dctakes.umlsuser=joshuawiener2 -Dctakes.umlspw=mypassword
>>>>>>>>>>> -cp "%CTAKES_HOME%/lib/*;%CTAKES_HOME%/desc/;%CTAKES_HOME%/resources/"
>>>>>>>>>>> -Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml
-Xms512M
>>>>>>>>>>> -Xmx2048M org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>
>>>>>>>>>>> :end
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Mon, Dec 23, 2013 at 9:44 PM, Masanz, James
J. <
>>>>>>>>>>> Masanz.James@mayo.edu> wrote:
>>>>>>>>>>>
>>>>>>>>>>>>  I see now that the java command in your
previous post didn’t
>>>>>>>>>>>> include the -cp parameter and its arguments.
>>>>>>>>>>>>
>>>>>>>>>>>> Please add that back in.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> *From:* joshuaweiner89@gmail.com [mailto:
>>>>>>>>>>>> joshuaweiner89@gmail.com] *On Behalf Of *Joshua
Weiner
>>>>>>>>>>>> *Sent:* Monday, December 23, 2013 8:12 PM
>>>>>>>>>>>>
>>>>>>>>>>>> *To:* user@ctakes.apache.org
>>>>>>>>>>>> *Subject:* Re: Adding UMLS username and password
....
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> James,
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> I appreciate your persistence, it means quite
a lot.
>>>>>>>>>>>> Unfortunately, even with your latest attempt
I still get the same error:
>>>>>>>>>>>>
>>>>>>>>>>>> Error: Could not find or load main class
>>>>>>>>>>>> org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> I am on windows 8, 8gb of ram.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thank you for your persistence.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Josh
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Mon, Dec 23, 2013 at 9:07 PM, Masanz,
James J. <
>>>>>>>>>>>> Masanz.James@mayo.edu> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>> Try this
>>>>>>>>>>>>
>>>>>>>>>>>> CD  C:\apache-ctakes-3.1.0
>>>>>>>>>>>>
>>>>>>>>>>>> set CTAKES_HOME=C:\apache-ctakes-3.1.0
>>>>>>>>>>>>
>>>>>>>>>>>> then enter the java command from the command
line that you were
>>>>>>>>>>>> entering
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Note: in my previous post, it was my mistake
of including the
>>>>>>>>>>>> percent signs in the SET command.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> I meant to suggest
>>>>>>>>>>>>
>>>>>>>>>>>> set CTAKES_HOME=""
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> *From:* joshuaweiner89@gmail.com [mailto:
>>>>>>>>>>>> joshuaweiner89@gmail.com] *On Behalf Of *Joshua
Weiner
>>>>>>>>>>>> *Sent:* Monday, December 23, 2013 7:55 PM
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> *To:* user@ctakes.apache.org
>>>>>>>>>>>> *Subject:* Re: Adding UMLS username and password
....
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> James,
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thank you for your continual prompt responses.
Unfortunately,
>>>>>>>>>>>> even after I did set%CTAKES_HOME%="" I still
get the following errror:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> C:\apache-ctakes-3.1.0>java -Dctakes.umlsuser=joshuawiener2
>>>>>>>>>>>> =DCtakes.umlspw=mypasswwordCTAKES_HOMECTAKES_HOMECTAKES_HOME/C:\apache-ctakes-3.1.0/config/log4j.xml
>>>>>>>>>>>> -Xmd512M -Xmx2048M org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>> Error: Could not find or load main class
>>>>>>>>>>>> org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> once again my code in the runctakesCVD.bat
file is:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> :okHome
>>>>>>>>>>>>
>>>>>>>>>>>> cd %CTAKES_HOME%
>>>>>>>>>>>>
>>>>>>>>>>>> java -Dctakes.umlsuser=joshuawiener2 -Dctakes.umlspw=passwordd
>>>>>>>>>>>> -cp "%CTAKES_HOME%/lib/*;%CTAKES_HOME%/desc/;%CTAKES_HOME%/resources/"
>>>>>>>>>>>> -Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml
-Xms512M
>>>>>>>>>>>> -Xmx2048M org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> :end
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Mon, Dec 23, 2013 at 8:45 PM, Masanz,
James J. <
>>>>>>>>>>>> Masanz.James@mayo.edu> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> You might try from the command line
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> echo  %CTAKES_HOME%
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> or even better for debug purposes put it
just before the  CD
>>>>>>>>>>>> %CTAKES_HOME%  line.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> It should respond with the parent of the
bin, desc, and
>>>>>>>>>>>> resources directory.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> If it responds with something else, try clearing
%CTAKES_HOME%
>>>>>>>>>>>> by entering the following on the command
line and then trying the bat file
>>>>>>>>>>>> again.
>>>>>>>>>>>>
>>>>>>>>>>>> set %CTAKES_HOME%=""
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Oh, and you’ll probably want to change
-Xmx1024M  to be  –Xmx2048M
>>>>>>>>>>>> or even larger or you will run into a heap
space error for many
>>>>>>>>>>>> parts of cTAKES.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> -- James
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> *From:* joshuaweiner89@gmail.com [mailto:
>>>>>>>>>>>> joshuaweiner89@gmail.com] *On Behalf Of *Joshua
Weiner
>>>>>>>>>>>> *Sent:* Monday, December 23, 2013 7:36 PM
>>>>>>>>>>>> *To:* user@ctakes.apache.org
>>>>>>>>>>>> *Subject:* Re: Adding UMLS username and password
....
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> James,
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks so much for your response. When I
remove the brackets I
>>>>>>>>>>>> still get an error, I get:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> "Error: could not find or load main class
>>>>>>>>>>>> org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thank you so much for your help. I appreciate
your dilligence.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Sincerely,
>>>>>>>>>>>>
>>>>>>>>>>>> Josh
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Mon, Dec 23, 2013 at 8:32 PM, Masanz,
James J. <
>>>>>>>>>>>> Masanz.James@mayo.edu> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>> Sorry for the confusion, don’t include
the brackets, so it
>>>>>>>>>>>> should look like this:
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> -Dctakes.umlsuser=joshuawiener2  -Dctakes.umlspw=mypassword
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> *From:* joshuaweiner89@gmail.com [mailto:
>>>>>>>>>>>> joshuaweiner89@gmail.com] *On Behalf Of *Joshua
Weiner
>>>>>>>>>>>> *Sent:* Monday, December 23, 2013 7:28 PM
>>>>>>>>>>>> *To:* user@ctakes.apache.org
>>>>>>>>>>>> *Subject:* Adding UMLS username and password
....
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>   Hey guys,
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> I know this is probably a dumb question but
I can't for the
>>>>>>>>>>>> life of me figure it out. I finally got a
UMLS username and password, but I
>>>>>>>>>>>> don't think I am updating the BAT files correctly...
here is what I did:
>>>>>>>>>>>> note my username is joshuaweiner2 and my
password (for this example) is
>>>>>>>>>>>> mypasswordd (see below).... I now can't get
the CVD to run.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thank you for your help...
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> :okHome
>>>>>>>>>>>>
>>>>>>>>>>>> cd %CTAKES_HOME%
>>>>>>>>>>>>
>>>>>>>>>>>> java -Dctakes.umlsuser=<joshuawiener2>
>>>>>>>>>>>> -Dctakes.umlspw=<mypasswordd> -cp
>>>>>>>>>>>> "%CTAKES_HOME%/lib/*;%CTAKES_HOME%/desc/;%CTAKES_HOME%/resources/"
>>>>>>>>>>>> -Dlog4j.configuration=file:/%CTAKES_HOME%/config/log4j.xml
-Xms512M
>>>>>>>>>>>> -Xmx1024M org.apache.uima.tools.cvd.CVD
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> :end
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Joshua S. Weiner
>>>>>>>>>>>>
>>>>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>>>>>
>>>>>>>>>>>> 201.638.0047
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Joshua S. Weiner
>>>>>>>>>>>>
>>>>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>>>>>
>>>>>>>>>>>> 201.638.0047
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Joshua S. Weiner
>>>>>>>>>>>>
>>>>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>>>>>
>>>>>>>>>>>> 201.638.0047
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> --
>>>>>>>>>>>> Joshua S. Weiner
>>>>>>>>>>>>
>>>>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>>>>>
>>>>>>>>>>>> 201.638.0047
>>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> --
>>>>>>>>>>> Joshua S. Weiner
>>>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>>>> 201.638.0047
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> --
>>>>>>>>> Joshua S. Weiner
>>>>>>>>> joshuaweiner2@gmail.com
>>>>>>>>> 201.638.0047
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>> Joshua S. Weiner
>>>>>>> joshuaweiner2@gmail.com
>>>>>>> 201.638.0047
>>>>>>>
>>>>>>
>>>>>>
>>>>
>>>>
>>>> --
>>>> Joshua S. Weiner
>>>> joshuaweiner2@gmail.com
>>>> 201.638.0047
>>>>
>>>
>>>
>>
>>
>> --
>> Joshua S. Weiner
>> joshuaweiner2@gmail.com
>> 201.638.0047
>>
>
>

Mime
View raw message