ctakes-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Masanz, James J." <Masanz.Ja...@mayo.edu>
Subject RE: Error running LVG Annotator
Date Mon, 10 Jun 2013 15:55:47 GMT

I checked in a fix for the issue:
https://issues.apache.org/jira/browse/CTAKES-208

Note however, that the LVGAnnotator.xml descriptor should not be used by itself, because it
relies on WordToken annotations being created by a tokenizer.  You won't see any results unless
you use it along with a tokenizer, which generally depends on a sentence detector which generally
relies on a sectionizer.

You might want to take a look at 
https://cwiki.apache.org/CTAKES/ctakes-30-component-use-guide.html



-----Original Message-----
From: user-return-195-Masanz.James=mayo.edu@ctakes.apache.org [mailto:user-return-195-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of Masanz, James J.
Sent: Monday, June 10, 2013 10:07 AM
To: 'user@ctakes.apache.org'
Subject: RE: Error running LVG Annotator

I understand better now. I thought you had created your own pipeline (aggregate descriptor).

It sounds like there is a bug in one of the LVG descriptors - that it isn't importing the
type system.

Most people don't run the descriptors within ctakes-lvg directly, but as part of a larger
pipeline.

I created Issue CTAKES-208 - LVG annotator: WordToken" used in java code but not declared
in the XML type Descriptor. has been successfully created.  to track this.  I will try to
get a more definitive answer today or tomorrow, stating exactly what needs to change.

This is the perfect place to ask question such as yours.  Please continue to ask questions
as you have them

-- James

From: user-return-194-Masanz.James=mayo.edu@ctakes.apache.org [mailto:user-return-194-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of Rajith Ravi
Sent: Monday, June 10, 2013 12:00 AM
To: user@ctakes.apache.org
Subject: Re: Error running LVG Annotator

Hi james
I have just followed the https://cwiki.apache.org/confluence/display/CTAKES/cTAKES+3.0+User+Install+Guide
and have done nothing more with any dependencies.
Am a newbie in apache cTakes and if your r mentioning ctakes-type-system-3.0.0-incubating.jar
it is there in lib folder of cTakes.

And is the TypeSystem file imported into your aggregate?
are you referring about TypeSystem.xml

Sorry for my limited knowledge.
what i was trying to do is after installing cTakes, i was just trying to all AE and find how
it is working, some of the issues searching through forums am able to solve, but some i couldn't
find any appropriate solutions.

thanks for the help.

rajith

On Sat, Jun 8, 2013 at 3:23 AM, Masanz, James J. <Masanz.James@mayo.edu> wrote:

Do you have ctakes-type-system as a dependency? And is the TypeSystem file imported into your
aggregate? (or are you using uimaFIT)
 
From: user-return-192-Masanz.James=mayo.edu@ctakes.apache.org [mailto:user-return-192-Masanz.James=mayo.edu@ctakes.apache.org]
On Behalf Of Rajith Ravi
Sent: Friday, June 07, 2013 5:13 AM
To: user@ctakes.apache.org
Subject: Error running LVG Annotator
 
Hi 

While trying to run LVG Annotator am getting the below mentioned error


org.apache.uima.analysis_engine.AnalysisEngineProcessException:jCas type "org.apache.ctakes.typesystem.type.syntax.WordToken"
used in java code but not declared in the XML type Descriptor.

can anyone help



regards

rajith


Mime
View raw message