ctakes-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Zbarcea (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CTAKES-458) Update Jenkins Continuous Integration jobs to use Maven 3.5.0
Date Thu, 28 Sep 2017 22:29:00 GMT

    [ https://issues.apache.org/jira/browse/CTAKES-458?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16185011#comment-16185011
] 

Alex Zbarcea commented on CTAKES-458:
-------------------------------------

Removed from {{MAVEN_OPTS}}: {{-XX:MaxPermSize=512m}} as:
{code}
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed
in 8.0
{code}

> Update Jenkins Continuous Integration jobs to use Maven 3.5.0
> -------------------------------------------------------------
>
>                 Key: CTAKES-458
>                 URL: https://issues.apache.org/jira/browse/CTAKES-458
>             Project: cTAKES
>          Issue Type: Improvement
>    Affects Versions: 4.0.0
>            Reporter: Alex Zbarcea
>            Priority: Minor
>
> Current Jenkins Jobs use Apache Maven {{3.0.5}}. Latest supported {{mvn}} on https://builds.apache.org
is {{3.5.0}}. 
> There are many versions in between, as such:
> * 3.1.x
> * 3.2.x
> * *3.3.x*
> * 3.4
> * 3.5
> Upgrading to latest {{mvn}} may have consequences related to
> * plugins being deprecated
> * properties being deprecated
> * more security enforcements
> * etc
> Also the Job should be:
> * Changes should be integrated with [jira:CTAKES|http://issues.apache.org/jira/browse/CTAKES]



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message