ctakes-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CTAKES-435) AE descriptors for processing CDA input is using deprecated assertion annotators
Date Thu, 20 Apr 2017 18:41:04 GMT

    [ https://issues.apache.org/jira/browse/CTAKES-435?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15977245#comment-15977245
] 

ASF subversion and git services commented on CTAKES-435:
--------------------------------------------------------

Commit 1792107 from james-masanz@apache.org in branch 'ctakes/trunk'
[ https://svn.apache.org/r1792107 ]

CTAKES-435  - update the assertion annotators that are being used by the Aggregate AEs that
can process CDA documents. (found in 4.0.0 rc3)

> AE descriptors for processing CDA input is using deprecated assertion annotators
> --------------------------------------------------------------------------------
>
>                 Key: CTAKES-435
>                 URL: https://issues.apache.org/jira/browse/CTAKES-435
>             Project: cTAKES
>          Issue Type: Bug
>          Components: ctakes-assertion, ctakes-clinical-pipeline
>    Affects Versions: 4.0.0
>            Reporter: James Joseph Masanz
>            Assignee: James Joseph Masanz
>            Priority: Minor
>             Fix For: future enhancement
>
>
> Found while testing rc3 for 4.0.0. This looks like something that can be fixed in the
next point release. Users can get an updated .xml file if they need a fix for this, which
will use the later version of the assertion annotators
> Symptoms:
> Using AggregateCdaUMLSProcessor.xml or AggregateCdaProcessor.xml
> Might notice the following warnings while loading the AE:
>  WARN BatchRunner - This class cannot be used until CTAKES-76 is implemented.
>  WARN JarafeMEDecoder - This class cannot be used until CTAKES-76 is implemented.
> The following occur when running the AE against a document:
>   WARN SingleDocumentProcessor - This class cannot be used until CTAKES-76 is implemented.
>   WARN SingleDocumentProcessor - This class cannot be used until CTAKES-76 is implemented.
>   WARN SingleDocumentProcessor - This class cannot be used until CTAKES-76 is implemented.
> And when run the AE, a stack trace that includes:
> Caused by: java.lang.NullPointerException
> 	at org.apache.ctakes.assertion.medfacts.AssertionAnalysisEngine.process(AssertionAnalysisEngine.java:213)
> 	at org.apache.uima.analysis_component.JCasAnnotator_ImplBase.process(JCasAnnotator_ImplBase.java:48)
> 	at org.apache.uima.analysis_engine.impl.PrimitiveAnalysisEngine_impl.callAnalysisComponentProcess(PrimitiveAnalysisEngine_impl.java:396)
> 	... 51 more



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message