ctakes-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Joseph Masanz (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (CTAKES-363) The smoking pipeline gives a URI is not hierarchical error
Date Tue, 14 Mar 2017 15:07:41 GMT

     [ https://issues.apache.org/jira/browse/CTAKES-363?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James Joseph Masanz closed CTAKES-363.
--------------------------------------
    Resolution: Workaround

In looking to see what changed between 3.1.1 and 3.2.2 since it was reported that this worked
in 3.1.1, I found it fails for me in 3.1.1 using the binary distribution:
Caused by: org.apache.uima.resource.ResourceInitializationException: Could not access the
resource data at file:/C:/Users/CH150124/workspaces/apache-ctakes/trunk/ctakes-smoking-status/desc/analysis_engine/ProductionPostSentenceAggregate_step1.xml.

The 3.1.1 convenience binary incorrectly has a path with CH150124 in it.

One workaround for 3.2.2 is as follows:
  Copy the directory ctakes-smoking-status-res\src\main\resources\org  from   ctakes-smoking-status-res
 to under  CTAKES_HOME\desc
  so you have a directory CTAKES_HOME\desc\org
  If you don't have a local copy of the source of  ctakes-smoking-status-res, you can check
out the needed directory from svn at
  https://svn.apache.org/repos/asf/ctakes/tags/ctakes-3.2.2-rc2/ctakes-smoking-status-res/src/main/resources/org

  Create CTAKES_HOME\desc\org\apache\ctakes\core
  Copy the directory analysis_engine from within ctakes-core\desc to under  CTAKES_HOME\desc\org\apache\ctakes\core
  Again, if you don't have the source version of 3.2.2. you can check out the needed directory
from svn from 
  https://svn.apache.org/repos/asf/ctakes/tags/ctakes-3.2.2-rc2/ctakes-core/desc/analysis_engine/

If we are going to support the SimulatedProdSmokingTAE.xml descriptor in the future, we either
need to change paths that are listed within it, or we need to include the directories listed
above in the convenience binary
 
Closing this as Workaround.
Suggest people switch to using something other than the CPE GUI once past the learning stage,
as using and maintaining the XML descriptors has fallen out of favor with many of the cTAKES
developers.



> The smoking pipeline gives a URI is not hierarchical error
> ----------------------------------------------------------
>
>                 Key: CTAKES-363
>                 URL: https://issues.apache.org/jira/browse/CTAKES-363
>             Project: cTAKES
>          Issue Type: Bug
>          Components: ctakes-smoking-status
>    Affects Versions: 3.2.1, 3.2.2
>         Environment: I have version 3.2.2 installed in both on a Windows and a Mac system.
>            Reporter: Harshad
>            Assignee: James Joseph Masanz
>
> I am trying to use the Smoking Pipeline using the User version (3.2.2).
> The following is the configuration I use:
> Descriptor: ../apache-ctakes-3.1.1/desc/ctakes-
> core/desc/collection_reader/FilesInDirectoryCollectionReader.xml
> Input Directory: an input folder with test data
> Analysis Engines: SimulatedProdSmokingTAE.xml 
> (in the ctakes-smoking-status folder)
> CAS Consumers: FIleWriterCasConsumer.xml
> This worked perfectly in v3.1.1 but now it is giving me an error : 
> 'org.apache.uima.resource.ResourceInitializationException:Initialization 
> of CAS processor with name "SimulatedProdAggregateTAE" failed.
> CausedBy: org.apache.uima.resource.ResourceConfigurationException:Initialization
> of CAS Processor with name "SimulatedProdAggregateTAE" failed.
> CausedBy: java.lang.IllegalArgumentException: URI is not hierarchical'



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message