ctakes-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Bethard (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CTAKES-171) jdom version breaks sectionizer
Date Thu, 21 Mar 2013 17:49:17 GMT

    [ https://issues.apache.org/jira/browse/CTAKES-171?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13609192#comment-13609192
] 

Steven Bethard commented on CTAKES-171:
---------------------------------------

I don't know who's using what, but it's possible to depend on both JDOM 1 and 2 at the same
time:

https://github.com/hunterhacker/jdom/issues/87

The correct versions would be:

org.jdom:jdom:1.1.3
org.jdom:jdom2:2.0.4

That should be enough to fix any dependency issues you're seeing. Of course, in the not so
distant future, it would be good to upgrade the JDOM 1 code to JDOM 2.
                
> jdom version breaks sectionizer
> -------------------------------
>
>                 Key: CTAKES-171
>                 URL: https://issues.apache.org/jira/browse/CTAKES-171
>             Project: cTAKES
>          Issue Type: Bug
>          Components: ctakes-core
>            Reporter: Tim Miller
>            Priority: Minor
>
> Recently the rule-based sectionizer (SectionSegmentAnnotator) has stopped working with
a NoSuchMethod error.  Pei says this roughly coincides with an attempt to move its libraries
to maven central.  Somehow the wrong version of jdom is being used, as copying over the version
originally used in ctakes fixes the issue.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message