ctakes-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pei Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CTAKES-166) RelationExtractorAggregate.xml is missing a name
Date Fri, 15 Mar 2013 20:26:12 GMT

    [ https://issues.apache.org/jira/browse/CTAKES-166?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13603804#comment-13603804
] 

Pei Chen commented on CTAKES-166:
---------------------------------

If you have spare time, do you want to also try adding the relation extractor aggregate to
the regression test?  And having this (pipeline as well as the xml desc configuration) automatically
tested in the future?
It should be as simple as adding a CPE to the directory.

/ctakes-regression-test/desc/collection_processing_engine/
Take a look at http://svn.apache.org/repos/asf/incubator/ctakes/trunk/ctakes-regression-test/desc/collection_processing_engine/CoreferenceCPETest.xml
For example:
1)	Just clone and point to the CPE to ../../../ctakes-relation-extractor/desc/analysis_engine/RelationExtractorAggregate.xml
instead .
2)	Run mvn test once (it should probably fail because there is nothing to compare with, but
just collect the generated results).
3)	Copy the results from generatedoutput/{NameofCPEFilename}/ into expectedoutput/{NameofCPEFilename}
4)	Check the expectedoutput into SVN.
5)	Now Every time mvn test is run, that CPE will executed and results compared automatically.

--Pei

                
> RelationExtractorAggregate.xml is missing a name
> ------------------------------------------------
>
>                 Key: CTAKES-166
>                 URL: https://issues.apache.org/jira/browse/CTAKES-166
>             Project: cTAKES
>          Issue Type: Bug
>          Components: ctakes-relation-extractor
>    Affects Versions: 3.0-incubating
>            Reporter: James Joseph Masanz
>            Priority: Minor
>             Fix For: 3.1-incubating
>
>
> The descriptor is created by uimaFIT, so it's not just necessarily editing and checking
in the descriptor for the long term fix.
> I noticed this while I was running 
> mvn -PrunCVD compile
> and tried to load the relation extractor aggregate.
> Just loading it gives an error about aggregate name is null
> To fix, replace this line
> <name/>
> with this
> <name>RelationExtractorAggregate</name>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message