ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zuo Yiming <yiming...@gmail.com>
Subject could not find or load main class org.apache.uima.tools.cvd.CVD
Date Thu, 06 Oct 2016 17:36:01 GMT
Hi guys,

Sorry to trouble you if you have seen my emails in the user mail list
before. I'm trying to run cTAKES purely based on command line on Windows
and when I type in  (bin\runctakesCVD.bat) , I got the following error:
Error: Could not find or load main class org.apache.uima.tools.cvd.CVD

I've tried to run cTAKES on Mac using only terminal before and it worked
fine. I compared my Mac and Windows and I believe the problem on my Windows
is that it won't take CTAKES_HOME/lib/* (more specifically in my case
uimaj-tool.jar) in the classpath when I specify it in java -cp command. I
reported this issue in the user mail list a few days ago but got no
response. Anyone tried to run cTAKES using command line on Windows before
and seen this issue? Any feedback will be highly appreciated.

-------------------------------------------
The command shows up in my windows server as follows.

java -cp "C:\Zuo\Github\cTAKES\apache-ctakes-3.2.2-win/desc/;C:\Zuo\
Github\cTAKES\apache-ctakes-3.2.2-win/resources/;C:\Zuo\
Github\cTAKES\apache-ctakes-3.2.2-win/lib/*" -Dlog4j.configuration=file:/C:
\Zuo\Github\cTAKES\apache-ctakes-3.2.2-win/config/log4j.xml -Xms512M -Xmx3g
org.apache.uima.tools.cvd.CVD

Best,
-- 
Yiming Zuo <https://sites.google.com/site/yimingzuo/>
Georgetown U. Medical Center:
Dr. Ressom's Omics Lab <http://omics.georgetown.edu/>
ECE Department of Virginia Tech:
Computational Bioinformatics & Bio-imaging Laboratory
<http://www.cbil.ece.vt.edu/>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message