ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charlie Forsgren <chafo...@student.liu.se>
Subject Problem connecting to database with YTEX
Date Thu, 30 Jul 2015 08:19:48 GMT
Hi!

I'm trying to set up YTEX using the ant.bat script but are getting errors.
The log-file says:

A:\Program\apache-ctakes-3.2.2\bin\ctakes-ytex\scripts>java -cp
A:\Program\apache-ctakes-3.2.2\lib\ant-1.9.2.jar;A:\Program\apache-ctakes-3.2.2\lib\ant-launcher-1.9.2.jar;A:\Program\apache-ctakes-3.2.2\lib\ant-contrib-1.0b3.jar
org.apache.tools.ant.Main -f build-setup.xml all
Buildfile:
A:\Program\apache-ctakes-3.2.2\bin\ctakes-ytex\scripts\build-setup.xml

dbping:

dbping:
     [java] DBPing: Connection to db failed - please check your settings
and try again
     [java]
com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could
not create connection to database server. Attempted reconnect 3 times.
Giving up.
[...]

     [java] ... 14 more

BUILD FAILED
A:\Program\apache-ctakes-3.2.2\bin\ctakes-ytex\scripts\build-setup.xml:52:
The following error occurred while executing this line:
A:\Program\apache-ctakes-3.2.2\bin\ctakes-ytex\scripts\data\build.xml:92:
Java returned: 1

Total time: 5

The user "ytex" has got the appropriate privileges along with the right
settings from the previous steps in the installation tutorial. The umls
database is there and up and running on 3306 and the firewall is allowing
traffic to and from the database locally. I'm running the latest version of
java and MySQL 5.6 with the "innodb_file_per_table"-setting turned off. I
can access and query the database through the MySQL command line where I
can view the populated databases from UMLS.

I haven't been able to find anyone with the same problem and I have been
trying to fix this for days now. Does anyone know what may be the issue?

-- 
Varma Hälsningar
Charlie Forsgren

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message