ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject RE: Developer install guide needs some changes
Date Tue, 14 Jul 2015 20:34:01 GMT
John,
Would you mind updating the doc directly?  If you send over your confluence wiki id (create
an account?) and we can grant the necessary karma.

> It doesn't seem to be necessary to download the Dictionaries and models separately, they
seem to be automatically downloaded by maven (in other words, skip steps 3-6 under Compile
a release in Eclipse).
Yes, you are correct.  If you're in eclipse IDE, the plugin's will automatically download
and unpack the dictionaries for you.

-----Original Message-----
From: John Mongan [mailto:john.mongan@ucsf.edu] 
Sent: Tuesday, July 14, 2015 4:27 PM
To: dev@ctakes.apache.org
Subject: Developer install guide needs some changes

Hello all -

I've been doing a fresh developer install and noted a couple things in the developer install
guide that could perhaps use some updating.

In particular:

The subversive plugin for maven (m2e) doesn't seem to work or be maintained any more. Subclipse
seems to be a functional replacement. You can install it from within Eclipse (Help | Install
Software...) by adding the following sites:

https://urldefense.proofpoint.com/v2/url?u=http-3A__subclipse.tigris.org_update-5F1.10.x&d=BQIF-g&c=qS4goWBT7poplM69zy_3xhKwEW14JZMSdioCoppxeFU&r=huK2MFkj300qccT8OSuuoYhy_xEYujfPwiAxhPVz5WY&m=dWC-QSjZCNbyj6WA4ZDErywyBCUzUmfeo0NzMFIYZ0k&s=mrcIbRnh3ngTylS1jZXZWMODXDHKeuKSADgGlvDf5ms&e=
 

install everything for subclipse, then add

https://urldefense.proofpoint.com/v2/url?u=http-3A__subclipse.tigris.org_m2eclipse_latest_&d=BQIF-g&c=qS4goWBT7poplM69zy_3xhKwEW14JZMSdioCoppxeFU&r=huK2MFkj300qccT8OSuuoYhy_xEYujfPwiAxhPVz5WY&m=dWC-QSjZCNbyj6WA4ZDErywyBCUzUmfeo0NzMFIYZ0k&s=Lv3anY0_mLEGEFW5mehGL2ELt56xBihEk62aTv5PJ_Y&e=


and install everything for m2e integration.

It doesn't seem to be necessary to download the Dictionaries and models separately, they seem
to be automatically downloaded by maven (in other words, skip steps 3-6 under Compile a release
in Eclipse).

If this information could be included in the developer install guide somewhere it may help
to save others some time.

Thanks,

John



Mime
View raw message