ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pei Chen <chen...@apache.org>
Subject Re: Mvn package error
Date Tue, 23 Jun 2015 13:59:39 GMT
Zhiwen,
I think this unit test needs to be updated/fixed.
Even though it runs fine in mvn compile test.  In the interim- package
needs to -DskipTests=true.

The longer story is that once modules are packaged (i.e. lvg, dictionary)
mvn loads them from the jars instead of unpacked resources.  So
essentially, the tests needs to have that packed in order to run the test.
Or modify lucene/hsqldb to have a Jar Reader.

On Mon, Jun 22, 2015 at 11:34 AM, Zhiwen Li <lizw@udel.edu> wrote:

> Hi,
> I tried to compile the 3.2.3 version of Ctakes, got the following error.
> Tests in error:
>
>  TestClearNLPPipeLine(org.apache.ctakes.dependency.parser.ae.util.TestClearNLPAnalysisEngines):
> URI is not hierarchical
> I realized this error was resolved before in this thread
> <https://issues.apache.org/jira/browse/CTAKES-307>
> But the same error comes up since the svg-ctakes-resources-lvg2008 was
> added to the dependency in revision 1642706.
> If I removed the dependency and basically restored it to revision 1620359
> <
> https://svn.apache.org/viewvc/ctakes/trunk/ctakes-lvg-res/pom.xml?view=markup&pathrev=1620359
> >,
> it compiles file. But I am not sure if this dependency is necessary or not.
> I don't know why this specific lvg version is required after revision
> 1642706.
> Please help to clarify.
>
> Thanks,
> Simon
>
> --
>
> Zhiwen Li
>
> lizw@udel.edu
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message