ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vijay Garla <vijay.ga...@yale.edu>
Subject Re: Question about YTEX
Date Wed, 10 Jun 2015 19:09:43 GMT
You should see a v_snomed_fword_lookup table in your database.

YTEX doesn't use all UMLS.  It filters to SNOMED-CT and RXNORM, and
specific Semantic Types

The script is uses is here:
https://svn.apache.org/repos/asf/ctakes/trunk/ctakes-ytex/scripts/data/mysql/umls/insert_view.template.sql

You can create a dictionary with different vocabularies/semantic types very
easily (just change the sql slightly).

For more detail on how this works, see
https://code.google.com/p/ytex/wiki/DictionaryLookup_V07 (docs slightly out
of date).

I have not tested this with the 'fast' dictionary lookup, but I think the
main speed gain of the fast lookup is due to skipping an extra(neous)
database query.

HTH,

VJ

On Wed, Jun 10, 2015 at 8:15 PM, Tsung-Ting Kuo <tskuo@ucsd.edu> wrote:

> BTW, my YTEX installation just completed, and the results is attached.
> Does my YTEX installation create dictionary lookup table with all
> concepts from the UMLS successfully?
>
>
>
> Thanks very much!
>
>
>
> Best regards,
>
> Tim
>
>
>
> *From:* Tsung-Ting Kuo [mailto:tskuo@ucsd.edu]
> *Sent:* Wednesday, June 10, 2015 9:49 AM
> *To:* 'Vijay Garla'; dev@ctakes.apache.org
> *Subject:* RE: Question about YTEX
>
>
>
> Hi Vijay,
>
>
>
> You are absolutely right – after changing the permission of the “resource”
> directory, YTEX start installing without problem! In the meanwhile, I have
> a quick question: since I have installed the UMLS database and set the
> “umls.schema” to UMLS database name (I am using MySQL), how do I know
> whether YTEX successfully creates a dictionary lookup table with all
> concepts from the UMLS or not?
>
>
>
> Thanks again!
>
>
>
> Best regards,
>
> Tim
>
>
>
> *From:* Vijay Garla [mailto:vijay.garla@yale.edu <vijay.garla@yale.edu>]
> *Sent:* Tuesday, June 9, 2015 11:31 PM
> *To:* tskuo@ucsd.edu; dev@ctakes.apache.org
> *Cc:* vijay.garla@yale.edu
> *Subject:* Re: Question about YTEX
>
>
>
> Hi Tsung-Ting,
>
>
>
> I see the following error:
>
>
>
> templateToConfig.extractTemplates:
>
>      [echo] unpacking ytex templates from
> /usr/local/apache-ctakes-3.2.2/lib/ctakes-ytex-res-3.2.2.jar to
> /usr/local/apache-ctakes-3.2.2/resources
>
>     [unzip] Expanding:
> /usr/local/apache-ctakes-3.2.2/lib/ctakes-ytex-res-3.2.2.jar into
> /usr/local/apache-ctakes-3.2.2/resources
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/conceptGraph/sct-rxnorm.template.xml
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/conceptGraph/sct-msh-csp-aod.template.xml
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/conceptGraph/sct-umls.template.xml
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/umls/model/UMLS.hbm.template.xml
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/dictionary/lookup/LookupDesc_stem_SNOMED.template.xml
>
>     [unzip] Unable to expand to file
> /usr/local/apache-ctakes-3.2.2/resources/org/apache/ctakes/ytex/dictionary/lookup/LookupDesc_SNOMED.template.xml
>
>
>
> I don't know why there was an issue extracting ctakes-ytex-res-3.2.2.jar.
> Can you make sure that  /usr/local/apache-ctakes-3.2.2/resources exists and
> is writable?
>
>
>
> -vj
>
>
>
> On Wed, Jun 10, 2015 at 12:17 AM, Tsung-Ting Kuo <tskuo@ucsd.edu> wrote:
>
> Hi Vijay Garla,
>
>
>
> I am Tsung-Ting Kuo from UCSD, and I am interested in your YTEX project. I
> tried to download it and setup based on the following page:
>
>
>
> https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__cwiki.apache.org_confluence_display_CTAKES_YTEX-2BInstallation&d=AwMFAg&c=-dg2m7zWuuDZ0MUcV7Sdqw&r=rw3vAb56jh8xMYlMHfE0hS2hfbV3RFxqvusA5jfoLnc&m=b0QIg7D5IImLEUt69gE-sqJU5GHeSBEMS_oz2Uddul4&s=Jyu357olHH-y9kNgTHIj2B01-i6DhsiGYH2HOwu9yok&e=>
>
>
>
> However, in the final step (step 7), I was not able to setup. The attached
> “setup.out” seems to show that the “UMLS.hbm.xml” is missing. Could you
> kindly help to tell me how to set it up?
>
>
>
> Thanks very much!
>
>
>
> Best regards,
>
> Tsung-Ting
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message