ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Devel <deve...@gmail.com>
Subject Re: UMLS Authentication failing despite correct username and password
Date Mon, 11 May 2015 22:15:30 GMT
I have the same ERROR, even when running the CVD and loading the clinical
pipeline.

The file cTakesHsql.xml contains the lines:


<property key="umlsUrl" value="
https://uts-ws.nlm.nih.gov/restful/isValidUMLSUser"/>

cTAKES was working fine last week and I did not make any config change
since then.

Does anyone have an idea how to resolve this?


On Mon, May 11, 2015 at 4:40 PM, Finan, Sean <
Sean.Finan@childrens.harvard.edu> wrote:

> Argh.  Our email server may have mucked with the url that I pasted:
>
> H t t p s : / / uts - ws . nlm . nih . gov / restful / isValidUMLSUser
>
> <property key="umlsUrl" value=" INSERT URL HERE, NO SPACES "/>
>
> -----Original Message-----
> From: Finan, Sean [mailto:Sean.Finan@childrens.harvard.edu]
> Sent: Monday, May 11, 2015 5:38 PM
> To: dev@ctakes.apache.org
> Subject: RE: UMLS Authentication failing despite correct username and
> password
>
> Hi Pedro,
>
>
>
> Check the cTakesHsql.xml and make sure that the line matches:
>
>
>
> <property key="umlsUrl" value="
> https://urldefense.proofpoint.com/v2/url?u=https-3A__uts-2Dws.nlm.nih.gov_restful_isValidUMLSUser&d=BQIGaQ&c=qS4goWBT7poplM69zy_3xhKwEW14JZMSdioCoppxeFU&r=fs67GvlGZstTpyIisCYNYmQCP6r0bcpKGd4f7d4gTao&m=bSJDuEveKkCQoYKfh2CwhxDx8I92siVZvxm45BoxGtE&s=A5wwcyQgQrPQ_dWwnaF-QHqZb0ttus_rzS-A6UDh-S8&e=
> "/>
>
>
>
> In an older version of cTAKES with an output message as you have:
>
> >>11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Default - Loading
> dictionary into memory.  Initial run may take few mins to load. Please be
> patient...
>
> That line got corrupted.
>
>
>
> Sean
>
>
>
> -----Original Message-----
>
> From: Pedro Teixeira [mailto:teixeira09@gmail.com]
>
> Sent: Monday, May 11, 2015 5:30 PM
>
> To: dev@ctakes.apache.org
>
> Subject: UMLS Authentication failing despite correct username and password
>
>
>
> So I've checked the Dictionary lookup XML file and that password works to
> log in via the website. This was also working last week but stopped at some
> point over the last week. I've got cTAKES running on a linux system so I
> can index batches of documents via a script. The exact error is as follows
> (with the username/password blocked out).
>
>
>
> 11 May 2015 15:59:26  INFO LvgCmdApiResourceImpl - cwd =
>
> /home/PT/cTAKES/apache-ctakes-3.2.1
>
> 11 May 2015 15:59:26  INFO LvgCmdApiResourceImpl - cd
> /home/PT/cTAKES/apache-ctakes-3.2.1/resources/org/apache/ctakes/lvg/
>
> 11 May 2015 15:59:27  INFO LvgCmdApiResourceImpl - cd
>
> /home/PT/cTAKES/apache-ctakes-3.2.1
>
> 11 May 2015 15:59:27  INFO ClearNLPDependencyParserAE - using Morphy
> analysis? true Loading configuration.
>
> Loading feature templates.
>
> Loading lexica.
>
> Loading model:
>
>
> ........................................................................................
>
> 11 May 2015 15:59:42  INFO Chunker - Chunker model file:
>
> org/apache/ctakes/chunker/models/chunker-model.zip
>
> 11 May 2015 15:59:44  INFO ContextDependentTokenizerAnnotator - Finite
> state machines loaded.
>
> 11 May 2015 15:59:44  INFO ConstituencyParser - Initializing parser...
>
> 11 May 2015 15:59:46  INFO ContextAnnotator - SCOPE ORDER: [1, 3]
>
> 11 May 2015 15:59:46  INFO NegationContextAnalyzer - initBoundaryData()
> called for ContextInitializer
>
> 11 May 2015 15:59:47  INFO POSTagger - POS tagger model file:
>
> org/apache/ctakes/postagger/models/mayo-pos.zip
>
> 11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Default - Loading
> dictionary into memory.  Initial run may take few mins to load. Please be
> patient...
>
> 11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Using dictionary
> lookup window type: org.apache.ctakes.typesystem.type.textspan.Sentence
>
> 11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Exclusion tagset
>
> loaded: CC CD DT EX IN LS MD PDT POS PP PP$ PRP PRP$ RP TO VB VBD VBG VBN
> VBP VBZ WDT WP WPS WRB
>
> 11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Using minimum term
> text span: 3
>
> 11 May 2015 15:59:47  INFO DictionaryDescriptorParser - Parsing dictionary
>
> specifications:
>
>
> /home/PT/cTAKES/apache-ctakes-3.2.1/resources/org/apache/ctakes/dictionary/lookup/fast/cTakesHsql.xml
>
> 11 May 2015 15:59:48 ERROR UmlsUserApprover - UMLS Account at
> https://urldefense.proofpoint.com/v2/url?u=https-3A__uts-2Dws.nlm.nih.gov_restful_isValidUMLSUser&d=BQIBaQ&c=qS4goWBT7poplM69zy_3xhKwEW14JZMSdioCoppxeFU&r=fs67GvlGZstTpyIisCYNYmQCP6r0bcpKGd4f7d4gTao&m=oVzYGAl69NhMu6lQpKeatJrIGk2o_z2AZvjq7Z5J69g&s=_JNevHgYhyKm5PjIyFlYxIS1UWuR7J-n5V551hou2dM&e=
> is not valid for user ######### with ###################### Couldn't
> initialize processing engine.
>
>   Initialization of CAS Processor with name
> "AggregatePlaintextFastUMLSProcessor" failed.
>
>
>
>
>
> I also have a test implementation on a local windows 8 laptop that also
> fails now due to the same error so it seems like it's UMLS related issue
> but I haven't heard back from them yet and was hoping perhaps someone with
> cTAKES has previously experienced and resolved the issue.
>
>
>
> Thanks!
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message