ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samir chabou <samir...@yahoo.com.INVALID>
Subject Re: UMLS Authentication failing despite correct username and password
Date Thu, 14 May 2015 02:46:12 GMT
I got the same error.Please verify your UMLS license settings in the DictionaryLookupAnnotatorUMLS.xml
configuration.
Although I'm able to connect to UMLS via the  website using my user name and password. Any
idea ? 
Thanks  


     On Monday, May 11, 2015 5:44 PM, "Finan, Sean" <Sean.Finan@childrens.harvard.edu>
wrote:
   

 Hi Pedro,

Check the cTakesHsql.xml and make sure that the line matches:

<property key="umlsUrl" value="https://uts-ws.nlm.nih.gov/restful/isValidUMLSUser"/>

In an older version of cTAKES with an output message as you have:
>>11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Default - Loading dictionary
into memory.  Initial run may take few mins to load. Please be patient...
That line got corrupted.

Sean

-----Original Message-----
From: Pedro Teixeira [mailto:teixeira09@gmail.com] 
Sent: Monday, May 11, 2015 5:30 PM
To: dev@ctakes.apache.org
Subject: UMLS Authentication failing despite correct username and password

So I've checked the Dictionary lookup XML file and that password works to log in via the website.
This was also working last week but stopped at some point over the last week. I've got cTAKES
running on a linux system so I can index batches of documents via a script. The exact error
is as follows (with the username/password blocked out).

11 May 2015 15:59:26  INFO LvgCmdApiResourceImpl - cwd =
/home/PT/cTAKES/apache-ctakes-3.2.1
11 May 2015 15:59:26  INFO LvgCmdApiResourceImpl - cd /home/PT/cTAKES/apache-ctakes-3.2.1/resources/org/apache/ctakes/lvg/
11 May 2015 15:59:27  INFO LvgCmdApiResourceImpl - cd
/home/PT/cTAKES/apache-ctakes-3.2.1
11 May 2015 15:59:27  INFO ClearNLPDependencyParserAE - using Morphy analysis? true Loading
configuration.
Loading feature templates.
Loading lexica.
Loading model:
........................................................................................
11 May 2015 15:59:42  INFO Chunker - Chunker model file:
org/apache/ctakes/chunker/models/chunker-model.zip
11 May 2015 15:59:44  INFO ContextDependentTokenizerAnnotator - Finite state machines loaded.
11 May 2015 15:59:44  INFO ConstituencyParser - Initializing parser...
11 May 2015 15:59:46  INFO ContextAnnotator - SCOPE ORDER: [1, 3]
11 May 2015 15:59:46  INFO NegationContextAnalyzer - initBoundaryData() called for ContextInitializer
11 May 2015 15:59:47  INFO POSTagger - POS tagger model file:
org/apache/ctakes/postagger/models/mayo-pos.zip
11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Default - Loading dictionary into
memory.  Initial run may take few mins to load. Please be patient...
11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Using dictionary lookup window type:
org.apache.ctakes.typesystem.type.textspan.Sentence
11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Exclusion tagset
loaded: CC CD DT EX IN LS MD PDT POS PP PP$ PRP PRP$ RP TO VB VBD VBG VBN VBP VBZ WDT WP WPS
WRB
11 May 2015 15:59:47  INFO AbstractJCasTermAnnotator - Using minimum term text span: 3
11 May 2015 15:59:47  INFO DictionaryDescriptorParser - Parsing dictionary
specifications:
/home/PT/cTAKES/apache-ctakes-3.2.1/resources/org/apache/ctakes/dictionary/lookup/fast/cTakesHsql.xml
11 May 2015 15:59:48 ERROR UmlsUserApprover - UMLS Account at https://urldefense.proofpoint.com/v2/url?u=https-3A__uts-2Dws.nlm.nih.gov_restful_isValidUMLSUser&d=BQIBaQ&c=qS4goWBT7poplM69zy_3xhKwEW14JZMSdioCoppxeFU&r=fs67GvlGZstTpyIisCYNYmQCP6r0bcpKGd4f7d4gTao&m=oVzYGAl69NhMu6lQpKeatJrIGk2o_z2AZvjq7Z5J69g&s=_JNevHgYhyKm5PjIyFlYxIS1UWuR7J-n5V551hou2dM&e=
 is not valid for user ######### with ###################### Couldn't initialize processing
engine.
  Initialization of CAS Processor with name "AggregatePlaintextFastUMLSProcessor" failed.


I also have a test implementation on a local windows 8 laptop that also fails now due to the
same error so it seems like it's UMLS related issue but I haven't heard back from them yet
and was hoping perhaps someone with cTAKES has previously experienced and resolved the issue.

Thanks!


  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message