ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject RE: Error when installing cTAKES 3.2.0-rc2
Date Mon, 03 Nov 2014 16:39:17 GMT
Lam Vu,
Have you tried running it with -DskipTests as a temp workaround?
Tests in error:
  TestClearNLPPipeLine(org.apache.ctakes.dependency.parser.ae.util.TestClearNLPAnalysisEngines):
URI
is not hierarchical

From: Lam Vu Son [mailto:lamvuson@gmail.com]
Sent: Friday, October 31, 2014 12:10 PM
To: dev@ctakes.apache.org
Subject: Error when installing cTAKES 3.2.0-rc2

Hello cTAKES community,

I am new to cTAKES and Maven. I am having problem with installing cTAKES 3.2.0-rc2 for developer.
I am sorry if this question is sent to an inappropriate address.

I followed instructions at this guide: https://cwiki.apache.org/confluence/display/CTAKES/cTAKES+3.0+Developer+Install+Guide.

I checked out Maven Projects from SCM (tag: https://svn.apache.org/repos/asf/ctakes/tags/ctakes-3.2.0-rc2/)
(the size of ctakes folder is about 2.5GB)
Checking out and importing was succesfull.
However, in Eclipse, I see many project with errors. I have cleaned and built all project,
but there are 1759 errors.

I tried to run UIMA_CVD--clinical_documents_pipeline.launch, select AggregatePlainTextProcessor.xml
as an AE, then I received a message box with error: "org.apache.uima.resource.ResourceInitializationException:
An import could not be resolved. No .xml file with name "org.apache.ctakes.assertion.types.TypeSystem"
was found in the class path or data path."

In "ctakes-clinical-pipeline" project, I noticed that there are missing files in Maven Dependencies
(such as ctakes-assertion-3.2.0.jar, ctakes-ytex-3.2.0.jar...) (please see attachment)

Then, I ran "mvn clean install", but this didn't solve the problem (please see attachement
for log file)

I appreciate your help in advance.

-Lam.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message