ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clayton Turner <caturn...@g.cofc.edu>
Subject v_snomed_fword_lookup view
Date Fri, 08 Aug 2014 18:07:36 GMT
Hi Everyone:

I have a question about how the v_snomed_fword_lookup view works when
running the CPE.

So my understanding of the view is that it is a view comprised of the
ytex.umls_aui_fword table, the umls.mrconso table and bits/pieces from
other umls tables.

I feel like this is not completely correct or my idea of how the join to
create the view works is off. For example, let's say I want the CPE to find
"malar ____" (e.g. malar rash) as a concept in the annotations. It never
happens after running my CPE descriptor and I cannot find it in my
v_snomed_fword_lookup view.

select count(*) from umls_aui_fword where fword='malar'; yields 34 results

select count(*) from umls.mrconso where str='malar'; yields 3 results.

So clearly these two tables know what the cui and context(s) are for malar
____. Yet, whenever I run a gold standard set of notes through the CPE,
malar is constantly flagged as just a word token and the concept is never
grabbed. This is recurrent for lots of other concepts, as well, I just
wanted to use an example to illustrate my issue.

Some troubleshooting I already went through:
1) Reinstalled ytex and umls database objects
2) Reinstalled a second time after redownloading umls through
metamorphosys, ensuring that snomed vocabularies were included (also
checked file sizes and noticed a big difference so I know those
vocabularies ARE included

Anyone got any ideas as to what the issue could be?

Thank you,
Clayton Turner

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message