ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Finan, Sean" <Sean.Fi...@childrens.harvard.edu>
Subject RE: v_snomed_fword_lookup view
Date Fri, 08 Aug 2014 19:48:10 GMT
Hi Clayton,

I don't know how the ytex dictionary lookup works, so I'm afraid that I can't help you with
an answer.  Maybe Vijay is the best person to do this.  If you aren't tied to ytex you could
try the new cTakes dictionary-lookup-fast.  I tested "Patient came in with a malar rash" and
it found "malar" and "malar rash".

Vijay,

At some point the lookup-fast module will be the default for the cTakes clinical pipeline.
 In order to synchronize the ytex lookup with cTakes, would you like to eventually work together
on reusing the same code for ytex?  I have no idea what ytex does, but I know the ins and
outs of the cdl-fast module.

Sean

> -----Original Message-----
> From: clayclay911@gmail.com [mailto:clayclay911@gmail.com] On Behalf Of
> Clayton Turner
> Sent: Friday, August 08, 2014 2:08 PM
> To: dev@ctakes.apache.org
> Subject: v_snomed_fword_lookup view
> 
> Hi Everyone:
> 
> I have a question about how the v_snomed_fword_lookup view works when
> running the CPE.
> 
> So my understanding of the view is that it is a view comprised of the
> ytex.umls_aui_fword table, the umls.mrconso table and bits/pieces from
> other umls tables.
> 
> I feel like this is not completely correct or my idea of how the join to
> create the view works is off. For example, let's say I want the CPE to find
> "malar ____" (e.g. malar rash) as a concept in the annotations. It never
> happens after running my CPE descriptor and I cannot find it in my
> v_snomed_fword_lookup view.
> 
> select count(*) from umls_aui_fword where fword='malar'; yields 34 results
> 
> select count(*) from umls.mrconso where str='malar'; yields 3 results.
> 
> So clearly these two tables know what the cui and context(s) are for malar
> ____. Yet, whenever I run a gold standard set of notes through the CPE,
> malar is constantly flagged as just a word token and the concept is never
> grabbed. This is recurrent for lots of other concepts, as well, I just
> wanted to use an example to illustrate my issue.
> 
> Some troubleshooting I already went through:
> 1) Reinstalled ytex and umls database objects
> 2) Reinstalled a second time after redownloading umls through
> metamorphosys, ensuring that snomed vocabularies were included (also
> checked file sizes and noticed a big difference so I know those
> vocabularies ARE included
> 
> Anyone got any ideas as to what the issue could be?
> 
> Thank you,
> Clayton Turner
Mime
View raw message