ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject Re: YTEX install - one error after building
Date Fri, 27 Jun 2014 22:29:44 GMT
VJ,
Could you confirm the implications? It probably does make sense to separate out the name:value
attributes. Even though they eventually resolve to the proper string... (So probably not a
show stopper for this release)

Sent from my iPhone

> On Jun 27, 2014, at 3:38 PM, "Masanz, James J." <Masanz.James@mayo.edu> wrote:
> 
> Thanks Pei!  I created 
> https://issues.apache.org/jira/browse/CTAKES-302
> 
> -----Original Message-----
> From: Chen, Pei [mailto:Pei.Chen@childrens.harvard.edu] 
> Sent: Friday, June 27, 2014 2:08 PM
> To: dev@ctakes.apache.org
> Subject: RE: YTEX install - one error after building
> 
> I presume the parameter markers should really have a property name attached to it:
> catalog="@filter.umls.catalog@" rather than "@filter.umls.catalog@" byitself in order
to pass xml validation.
> 
>> -----Original Message-----
>> From: Masanz, James J. [mailto:Masanz.James@mayo.edu]
>> Sent: Friday, June 27, 2014 2:59 PM
>> To: 'dev@ctakes.apache.org'
>> Subject: RE: YTEX install - one error after building
>> 
>> I had a workspace in eclipse that I had checked out 6/6 but never built.
>> Today I did a Team->Update and then File->Import->Existing Maven Projects
>> to pick up new modules such as temporal relations
>> 
>> Now during build I am getting the same kind of error Paula was seeing a few
>> months ago:
>> 
>> Description    Resource    Path    Location    Type
>> Element type "hibernate-mapping" must be followed by either attribute
>> specifications, ">" or "/>".    UMLS.hbm.template.xml    /ctakes-ytex-
>> res/src/main/resources/org/apache/ctakes/ytex/umls/model    line 27    XML
>> Problem
>> 
>> This is on Windows 7 with Eclipse 4.2.2
>> 
>> Line 27 is the second line of this XML fragment:
>> <hibernate-mapping package="org.apache.ctakes.ytex.umls.model"
>>    schema="@umls.schema@" @filter.umls.catalog@>
>> 
>> Are there parts of these instructions that still apply?
>> https://cwiki.apache.org/confluence/display/CTAKES/YTEX+Installation
>> 
>> Since mine was not a fresh check out from SVN, will people who check out
>> fresh from trunk need to perform any of those steps?
>> 
>> -- James
>> 
>> 
>> -----Original Message-----
>> From: digital paula [mailto:cybersation@hotmail.com]
>> Sent: Wednesday, March 26, 2014 7:05 PM
>> To: dev@ctakes.apache.org
>> Subject: RE: YTEX install - one error after building
>> 
>> Thanks VJ.  I did try disabling validation in eclipse but that didn't work.  At any
>> rate, I see that there is also a 'ytex installation' link on the ctakes wiki that
 I
>> did not follow (I was still referring to your code.google.com site where ytex
>> was previously stored) which also seems to align to the readme file link you
>> provided.  I might not be able to get to till the weekend but will let you know
>> but I'm sure it will work once I execute according to  instructions.
>> 
>>> Date: Wed, 26 Mar 2014 10:03:33 -0400
>>> Subject: Re: YTEX install - one error after building
>>> From: vngarla@gmail.com
>>> To: dev@ctakes.apache.org
>>> 
>>> Hi Paula,
>>> 
>>> UMLS.hbm.template.xml is a template used to generate a valid hibernate
>>> xml config file.  If you have imported YTEX into eclipse, follow these
>>> guidelines:
>>> 
>>> https://svn.apache.org/repos/asf/ctakes/branches/ytex/ctakes-
>> ytex/READ
>>> ME
>>> 
>>> I believe the issue might be that you have validation enabled for XML;
>>> I believe you can disable it for specific files (like UMLS.hbm.template.xml).
>>> I am using keper, and it doesn't complain about
>>> UMLS.hbm.template.xml; I'm not sure if I tweaked my validator settings.
>>> 
>>> -vj
>>> 
>>> 
>>> 
>>> On Tue, Mar 25, 2014 at 6:16 PM, digital paula
>> <cybersation@hotmail.com>wrote:
>>> 
>>>> Hi VJ,
>>>> 
>>>> As part of testing, I  did a fresh install of cTAKES with YTEX and
>>>> everything installed correctly but after building I got one error
>>>> pertaining to this page, five lines down.
>>>> 
>>>> 
>>>> https://svn.apache.org/repos/asf/ctakes/branches/ytex/ctakes-ytex-re
>> s/src/main/resources/org/apache/ctakes/ytex/umls/model/UMLS.hbm.tem
>> p
>>>> late.xml
>>>> 
>>>> 
>>>> The error is this line:
>>>> <hibernate-mapping package="org.apache.ctakes.ytex.umls.model"
>>>> schema="@umls.schema@" @filter.umls.catalog@>
>>>> 
>>>> Using Eclipse Juno, the error states:
>>>> 
>>>> Element type "hibernate-mapping" must be followed by either
>>>> attribute specifications, ">" or "/>".
>>>> 
>>>> I tried using /> instead of > and putting it all on one line instead
>>>> of two but can't seem to fix it.
>>>> 
>>>> Also,  I was about to install the sectionizer separately as a module
>>>> but I see that YTEX already has a
>>>> sectionizer(SegmentRegexSectionizer) so I look forward to exploring it
>> further.
>>>> 
>>>> Regards,
>>>> Paula
>>>> 
>>>>> Date: Thu, 20 Mar 2014 14:08:32 -0400
>>>>> Subject: Re: YTEX Doc in cwiki
>>>>> From: vngarla@gmail.com
>>>>> To: dev@ctakes.apache.org
>>>>> 
>>>>> I plan to fix all the links.
>>>>> 
>>>>> I have not yet moved the scripts for the semantic similarity
>>>>> benchmark to cTAKES, so I dropped that from the cTAKES semantic
>>>>> similarity docs.  When those scripts get moved to cTAKES, I'll update
the
>> docs.
>>>>> 
>>>>> 
>>>>> On Thu, Mar 20, 2014 at 12:33 PM, Masanz, James J. <
>>>> Masanz.James@mayo.edu>wrote:
>>>>> 
>>>>>> hi vijay,
>>>>>> 
>>>>>> I have just skimmed a few sections so far.
>>>>>> 
>>>>>> the page has links at the top to google docs pages and then
>>>>>> links to
>>>> our
>>>>>> web pages (the children pages) at the bottom. Is your intent to
>>>>>> remove
>>>> the
>>>>>> first 3 links once things are finalized?
>>>>>> 
>>>>>> some of the examples on the Semantic+Similarity page use "cd
>>>> CTAKES_HOME"
>>>>>> but later use %CTAKES_HOME%
>>>>>> 
>>>>>> so it looks like you meant cd %CTAKES_HOME%
>>>>>> 
>>>>>> I didn't see anything about the Similarity Benchmark on the new
>> pages.
>>>> Is
>>>>>> that still part of ytex?
>>>>>> 
>>>>>> -- james
>>>>>> 
>>>>>> 
>>>>>> -----Original Message-----
>>>>>> From: vijay garla [mailto:vngarla@gmail.com]
>>>>>> Sent: Sunday, March 16, 2014 8:53 PM
>>>>>> To: dev@ctakes.apache.org
>>>>>> Subject: YTEX Doc in cwiki
>>>>>> 
>>>>>> Hello All,
>>>>>> 
>>>>>> I've made a first cut at moving and updating the YTEX docs over
>>>>>> from
>>>> google
>>>>>> code to the cTAKES confluence site.
>>>>>> 
>>>>>> This is a first cut, and I'm trying to keep the YTEX docs
>>>>>> separated,
>>>> as it
>>>>>> is not yet in trunk/released, and I don't want to mess up any
>>>>>> existing docs.
>>>>>> 
>>>>>> see https://cwiki.apache.org/confluence/display/CTAKES/YTEX+3.2
>>>>>> 
>>>>>> Best,
>>>>>> 
>>>>>> VJ
>> 

Mime
View raw message