ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Masanz, James J." <Masanz.Ja...@mayo.edu>
Subject RE: Command line invocation
Date Mon, 14 Apr 2014 14:52:46 GMT
Did you by chance miss the step where you 
"Download the cTAKES resources ZIP file with a matching version from the ctakesresources project"

Do you have a directory such as 
resources/org/apache/ctakes/dictionary/lookup/umls*
such as
resources/org/apache/ctakes/dictionary/lookup/umls2011ab


-----Original Message-----
From: Abraham Tom [mailto:atom@practicefusion.com] 
Sent: Sunday, April 13, 2014 11:49 AM
To: dev@ctakes.apache.org
Subject: RE: Command line invocation

Thanks for the information

I was on the developer version, but now I have reverted to the user version 

I reinstalled cTakes, specifically apache-ctakes-3.1.0-bin.tar.gz and followed the instructions
from https://cwiki.apache.org/confluence/display/CTAKES/cTAKES+3.1+User+Install+Guide 

Then I tried to execute the following 
java -cp $CTAKES_HOME/lib/*:$CTAKES_HOME/desc/:$CTAKES_HOME/resources/  -Xms512M -Xmx1024M
org.apache.ctakes.clinicalpipeline.ClinicalPipelineWithUmls

and I got the following message
Exception in thread "main" org.apache.uima.resource.ResourceInitializationException

Then I tried to invoke the jar intself

java -jar  -Xms512M -Xmx1024M ./lib/ctakes-clinical-pipeline-3.1.0.jar 

but I got the following error
Failed to load Main-Class manifest attribute from
./lib/ctakes-clinical-pipeline-3.1.0.jar


Groovy is an option if I there are instructions on how to use it
I would not mind helping to build those instructions to invoke specific classes

Best regards,

Abraham Tom
____________________________
Abraham Tom
Data Warehouse Engineer
 
-----Original Message-----
From: Masanz, James J. [mailto:Masanz.James@mayo.edu] 
Sent: Sunday, April 13, 2014 5:32 AM
To: 'dev@ctakes.apache.org'
Subject: RE: Command line invocation


Yes, that's possible.

You need more things on your classpath - you can take a look at the classpath within runctakesCVD.bat

Or if you are open to using groovy, take a look at the scripts directory within ctakes-core

-----Original Message-----
From: Abraham Tom [mailto:atom@practicefusion.com]
Sent: Saturday, April 12, 2014 10:55 AM
To: dev@ctakes.apache.org
Subject: Command line invocation

I am not a core java developer, I am a Hadoop data guy We are experimenting with using cTakes
and we have no Java developers in house

I am trying to invoke ClinicalPipelineWithUmls on a server where I installed the developer
cTakes.   This invocation is done via the following command line

java -verbose -cp "/opt/cTAKES-3.1.1/ctakes-clinical-pipeline/target/classes;/home/mapr/.m2/repository/org/cleartk/cleartk-util/0.9.2/cleartk-util-0.9.2.jar"
org.apache.ctakes.clinicalpipeline.ClinicalPipelineWithUmls

but I am getting a Class not found error

I would like to invoke via command line so that I can wrap a shell script around it and automate
the processing of various docs.

This should be possible shouldn't it?


Best regards,

Abraham Tom


Mime
View raw message