ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Masanz, James J." <Masanz.Ja...@mayo.edu>
Subject RE: YTEX LVG Fix
Date Wed, 12 Feb 2014 17:41:39 GMT

Don't know how we'd find out if anyone is still using it.

+1 for upgrading resources.

-----Original Message-----
From: Pei Chen [mailto:chenpei@apache.org] 
Sent: Wednesday, February 12, 2014 10:38 AM
To: dev@ctakes.apache.org
Subject: Re: YTEX LVG Fix

+1 for upgrading the LVG resources...
Not sure how many people are still using the pad term spotter module-
perhaps we could think about deprecating it if no one is using it??
--Pei


On Wed, Feb 12, 2014 at 11:24 AM, John David Osborne (Campus) <
ozborn@uab.edu> wrote:

> Thanks Vijay.
>
> I'm going to do the rebuild, but one thing I noticed is that YTEX is using
> the 2008 version of LVG and the old PAD term spotter looks like it is
> using the one from 2004!
>
> I guess they can both use different versions (each one living in its own
> directory), but given how dated that LVG is (and the number of
> improvements) maybe we should upgrade and/or share LVG? What do others
> think?
>
> I'm likely going to do the rebuild of the ytex branch with an newer
> version of LVG and see how it goes. I'm not sure how the PAD term spotter
> would like that though - it looks like it is using MySQL instead of HSQL.
>
> --
> John David Osborne
>
> Research Associate
> University of Alabama at Birmingham
> Biomedical Informatics
> Center for Clinical and Translational Science
> 1720 7th Avenue South
> Sparks Building, Suite 175
> Birmingham, AL, 35294
>
>
>
>
>
> On 2/11/14 8:19 PM, "vijay garla" <vngarla@gmail.com> wrote:
>
> >Hi John,
> >
> >Thanks for this.  I've updated the YTEXPipeline, fixed the lvg paths in
> >SetupAUIFirstWord.
> >
> >If you want to re-run SetupAUIFirstWord (not necessary unless you are
> >using
> >the stemmed words for dictionary lookup), just svn update, rebuild
> >ctakes-ytex-uima, and copy the jar to the lib dir of your ctakes install.
> >
> >Best,
> >
> >VJ
> >
> >
> >On Mon, Feb 10, 2014 at 6:25 PM, John David Osborne (Campus)
> ><ozborn@uab.edu
> >> wrote:
> >
> >>  These were the changes I made to get the YTEX pipeline working with LVG
> >> (2008). It looks like there were just a couple of spots with some old
> >> hard-coded paths in SetupAUIFirstWord.java that were appropriate to the
> >>old
> >> ytex directory structure.
> >>
> >> For now I have just swapped them out to fit with the new directory
> >> structure, but I suppose the correct fix may be to extract them out
> >> somewhere...  In any case I don't have write privileges, some someone
> >>else
> >> may want to fix this (Vijay?)
> >>
> >> I also included the YTEXPipeline.xml descriptor file I fixed as well in
> >> case anybody needs it.
> >>
> >>  -John
> >>
> >>
> >>
>
>

Mime
View raw message