ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Bethard <steven.beth...@gmail.com>
Subject Re: scala and groovy
Date Fri, 13 Dec 2013 17:27:47 GMT
On Fri, Dec 13, 2013 at 10:32 AM, Masanz, James J.
<Masanz.James@mayo.edu> wrote:
> The bigger issue is the following
> I was getting an error about scala, so I added the following to the Grapes annotation
in my groovy script
> @Grab(group='org.scala-lang', module='scala-library', version='2.9.0'),
> @Grab(group='org.scala-tools.sbinary', module='sbinary_2.9.0', version='0.4.0'),

Do you know what depends on Scala?

> Those grapes now appear in my grapes repo. But I am getting the following error, and
I don't know why ScopeParser cannot "see" scala.ScalaObject which I believe is defined in
one of the scala jars that I added to the rootLoader as I described above.

In the past, when I was seeing this kind of error with Scala, it
sometimes meant that I had the wrong version of Scala. Is that
possible here?

Steve

P.S. I've stayed out of this whole Groovy thing because we (at
ClearTK) had some bad experiences with Groovy in the past. Mainly with
Groovy scripts getting out of sync with the rest of the code base,
just like XML descriptors, though perhaps the IDEs and Maven are
better now and that's no longer a problem? But this whole "grape"
thing instead of standard Maven isn't changing my mind. Not that I
planned to switch away from Scala for my scripting anyway, but...

Mime
View raw message