ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chase Master <chasemast...@gmail.com>
Subject Re: Incorrect frequency in Drug NER?
Date Wed, 04 Sep 2013 15:26:19 GMT
Hi,
I've been experimenting with the Drug NER module as well.  I noticed that
for the phrase "Ibuprofen increased from 200 mg to 300 mg p.o. once a day."
the medicationFrequency has number = 1, but unit = null for the Ibuprofen
with strength 300 mg.  Also, for the phrase "Aspirin 200-mg once-a-day",
there is no medicationFrequency, whereas for the phrase "Aspirin 200-mg
once a day" medicationFrequency has number = 1, unit = day.  I have noticed
this behaviour on both v3.0 and the trunk.

Thanks


On Wed, Aug 28, 2013 at 12:55 PM, Kannan Thiagarajan <kannanth@gmail.com>wrote:

> Thanks James.
>
>
> On Wed, Aug 28, 2013 at 11:51 AM, Masanz, James J. <Masanz.James@mayo.edu
> >wrote:
>
> > This looks like a bug. I've created CTAKES-230
> > https://issues.apache.org/jira/browse/CTAKES-230
> >
> >
> > -----Original Message-----
> > From: dev-return-1879-Masanz.James=mayo.edu@ctakes.apache.org [mailto:
> > dev-return-1879-Masanz.James=mayo.edu@ctakes.apache.org] On Behalf Of
> > Kannan Thiagarajan
> > Sent: Sunday, August 25, 2013 7:20 PM
> > To: dev@ctakes.apache.org
> > Subject: Incorrect frequency in Drug NER?
> >
> > Hello,
> >
> > I just ran into an issue where I'm getting an incorrect Medication
> > Frequency while running the Drug NER processor
> > (DrugAggregatePlaintextUMLSProcessor.xml). I tried this via the CVD
> > environment. I gave a couple of different texts and noticed the issue.
> >
> > 1) The text  "Apply Bacitracin to affected area on feet twice a day" -
> > seems to work correctly and gives a Frequency number of "2" and unit as
> > "day"
> >
> > 2) The text ""Apply Bacitracin to affected area on feet twice a day *for
> > one week*" - seems to trip up and gives an Frequency number of "1" and
> unit
> > as "week".
> >
> >
> > I tried other variations such as
> >
> > "for 7 day"
> > "for 2 weeks"
> > "for 1 month"
> >
> > and they seem to work fine and in all cases the Duration seems to be
> fine.
> >
> >
> > Any thoughts?
> >
> > Just for the record, I'm running with a recently updated trunk version of
> > the code.
> >
> > --
> > Best Regards
> > Kannan Thiagarajan
> >
>
>
>
> --
> Best Regards
> Kannan Thiagarajan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message