ctakes-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Pei" <Pei.C...@childrens.harvard.edu>
Subject RE: supported java releases in current ctakes development and future releases (3.1 and later)
Date Mon, 03 Jun 2013 20:41:47 GMT
I believe so; do you know which component you were planning to require the java 1.7 features?
(existing component or new?)
The one consideration is that if 3.1 is planned to be cut from trunk and released soon (end
of this month?), it may be a good idea to isolate the project first (such as sandbox if it's
a new component or a temp branch); just in case there isn't enough time or issues with 1.7
testing.  My initial 2 cents...

--Pei


> -----Original Message-----
> From: Coarr, Matt [mailto:mcoarr@mitre.org]
> Sent: Monday, June 03, 2013 4:33 PM
> To: dev@ctakes.apache.org
> Subject: Re: supported java releases in current ctakes development and
> future releases (3.1 and later)
> 
> Just to tie back to this, it sounds like it's ok to use java 7 features.  Right?
> 
> Anything that works with ctakes using java 1.7 should work work with uima
> requiring at least 1.5 or 1.6.  I know I've been running 1.7 for about a year or
> so.
> 
> (The reason I'm asking is a coworker is making some changes and would like
> to use named capturing groups in the java 7 regex support —
> http://docs.oracle.com/javase/7/docs/api/java/util/regex/Pattern.html#gro
> upname )
> 
> A couple of my other favorite java7 features that I've used on non-ctakes
> projects:
> 
>   *   multicatch:
> http://docs.oracle.com/javase/7/docs/technotes/guides/language/catch-
> multiple.html
>   *   autoclosable resources (aka "try-with-resources"):
> http://docs.oracle.com/javase/7/docs/technotes/guides/language/try-with-
> resources.html
>   *   concurrency utility enhancements (aka "fork-join"):
> http://docs.oracle.com/javase/7/docs/technotes/guides/concurrency/chang
> es7.html
> 
> Matt
> 
> 
> From: <Chen>, Pei
> <Pei.Chen@childrens.harvard.edu<mailto:Pei.Chen@childrens.harvard.edu>
> >
> Reply-To: "dev@ctakes.apache.org<mailto:dev@ctakes.apache.org>"
> <dev@ctakes.apache.org<mailto:dev@ctakes.apache.org>>
> Date: Thursday, May 23, 2013 18:29
> To: "dev@ctakes.apache.org<mailto:dev@ctakes.apache.org>"
> <dev@ctakes.apache.org<mailto:dev@ctakes.apache.org>>
> Subject: RE: supported java releases in current ctakes development and
> future releases (3.1 and later)
> 
> good idea...
> FYI:
> Opened to track this:
> https://issues.apache.org/jira/browse/CTAKES-197
> Historically, Java has been pretty good about backwards compatibility, but I
> think we should still test and verify (not just cTAKES, but our dependencies
> as well).
> 
> --Pei
Mime
View raw message