crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Micah Whitacre (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-582) Upgrade Guava Dependency to 0.18
Date Wed, 20 Jan 2016 01:38:39 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-582?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15107801#comment-15107801
] 

Micah Whitacre commented on CRUNCH-582:
---------------------------------------

With CRUNCH-581 we are stuck with Guava due to it being part of our API but what if we removed
it all except for where it is part of our API.  This would mitigate any compliance issue we
might have with consumers trying to pick between 18 and 14 (theoretically), right?

> Upgrade Guava Dependency to 0.18
> --------------------------------
>
>                 Key: CRUNCH-582
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-582
>             Project: Crunch
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Micah Whitacre
>            Assignee: Josh Wills
>         Attachments: CRUNCH-582.patch
>
>
> Mentioned on CRUNCH-356, the version of Guava on which Crunch is currently based is quite
old and several of the APIs used have been removed making it difficult for consumer to use
later versions of Guava.  Upgrading to the latest released version (18.0) should help keep
the dependencies modern.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message