crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Wills (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-582) Upgrade Guava Dependency to 0.18
Date Tue, 19 Jan 2016 06:35:39 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-582?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15106330#comment-15106330
] 

Josh Wills commented on CRUNCH-582:
-----------------------------------

Are there any opinions on 14.0.1 as a compromise between 11.0.2 and 18.0?

> Upgrade Guava Dependency to 0.18
> --------------------------------
>
>                 Key: CRUNCH-582
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-582
>             Project: Crunch
>          Issue Type: Improvement
>          Components: Core
>            Reporter: Micah Whitacre
>            Assignee: Josh Wills
>         Attachments: CRUNCH-582.patch
>
>
> Mentioned on CRUNCH-356, the version of Guava on which Crunch is currently based is quite
old and several of the APIs used have been removed making it difficult for consumer to use
later versions of Guava.  Upgrading to the latest released version (18.0) should help keep
the dependencies modern.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message