crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Micah Whitacre (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-574) Update commons-lang from both 2.4/2.5 to 2.6
Date Mon, 19 Oct 2015 02:29:05 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-574?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14962766#comment-14962766
] 

Micah Whitacre commented on CRUNCH-574:
---------------------------------------

Looks like current version of commons-lang for hadoop-client in master resolves to 2.6.  So
we should still be compatible with this change from a Hadoop standpoint.  Looks like HBase
works with 2.6 as well.

> Update commons-lang from both 2.4/2.5 to 2.6
> --------------------------------------------
>
>                 Key: CRUNCH-574
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-574
>             Project: Crunch
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 0.12.0
>            Reporter: Sean Owen
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: CRUNCH_574.patch
>
>
> I've got a request here to update the {{commons-lang}} dependency used in Crunch to 2.6.
Right now, the pom actually specifies both 2.4 and 2.5 (2.5 wins). These are all old versions
anyway. Should be strictly compatible (https://commons.apache.org/proper/commons-lang/release-notes/RELEASE-NOTES-2.6.txt)
and tests pass.
> CC [~tomwhite]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message