crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Tzolov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CRUNCH-500) Maven Site Plugin (e.g site:site) causes AetherClassNotFound on Maven 3.2.x and newer
Date Mon, 23 Feb 2015 10:12:12 GMT

     [ https://issues.apache.org/jira/browse/CRUNCH-500?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christian Tzolov updated CRUNCH-500:
------------------------------------
    Description: 
As explained here: 
https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound
the error is caused by Maven 3.1-alpha-1 migration from Sonatype Aether to Eclipse Aether
which is an incompatible change for some plugins.

Suggested solution is to upgrade the maven-site-plugin version to 3.3 (at the moment Crunch
uses 3.1). The new version (3.3) should be backward compatible and work with Maven 3.0.x and
3.1.x:

  was:
As explained here: 
https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound
the error is caused by Maven 3.1-alpha-1 migration from Sonatype Aether to Eclipse Aether
which is an incompatible change for some plugins.

Suggested solution is to upgrade the maven-site-plugin version to 3.3 (at the moment Crunch
usages 3.1). The new version (3.3) should be backward compatible and work with Maven 3.0.x
and 3.1.x:


> Maven Site Plugin (e.g site:site) causes AetherClassNotFound on Maven 3.2.x and newer
> -------------------------------------------------------------------------------------
>
>                 Key: CRUNCH-500
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-500
>             Project: Crunch
>          Issue Type: Bug
>            Reporter: Christian Tzolov
>            Priority: Trivial
>
> As explained here: 
> https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound
> the error is caused by Maven 3.1-alpha-1 migration from Sonatype Aether to Eclipse Aether
which is an incompatible change for some plugins.
> Suggested solution is to upgrade the maven-site-plugin version to 3.3 (at the moment
Crunch uses 3.1). The new version (3.3) should be backward compatible and work with Maven
3.0.x and 3.1.x:



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message