crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Whiting (JIRA)" <>
Subject [jira] [Commented] (CRUNCH-484) Add library features from spotify/crunch-lib into crunch-core
Date Sat, 03 Jan 2015 21:26:35 GMT


David Whiting commented on CRUNCH-484:

I think Gabriel's right about the Quantiles name. AFAIK there's only one team using the "Percentiles"
named implementation, so now's the time to change it if we're going to.

> Add library features from spotify/crunch-lib into crunch-core
> -------------------------------------------------------------
>                 Key: CRUNCH-484
>                 URL:
>             Project: Crunch
>          Issue Type: Improvement
>          Components: Core
>            Reporter: David Whiting
>            Assignee: Josh Wills
>         Attachments: 0001-CRUNCH-484-Add-library-features-from-spotify-crunch-.patch,
> As suggested by Josh, I've patched the more generally-applicable stuff from
into org.apache.crunch.lib
> Open questions:
> - Does all of this belong here?
> - Should Percentiles be renamed to Quantiles, given that you actually just specify a
0.0-1.0 range? Quantiles is more accurate, but people are more likely to search for Percentiles.
> - Would the DoFns.detach(...) functionality be better implemented as a DetachingReduceFn
base class rather than a wrap-and-delegate?

This message was sent by Atlassian JIRA

View raw message