crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Wills <josh.wi...@gmail.com>
Subject Re: news, releases, etc.
Date Wed, 23 Apr 2014 07:45:27 GMT
Alright, I'm on board with 0.10.0. Will start cranking on it tomorrow.
On Apr 22, 2014 11:41 PM, "Gabriel Reid" <gabriel.reid@gmail.com> wrote:

> On Wed, Apr 23, 2014 at 7:27 AM, Josh Wills <jwills@cloudera.com> wrote:
> > On Tue, Apr 22, 2014 at 12:09 AM, Gabriel Reid <gabriel.reid@gmail.com
> >wrote:
> >>
> >> Interesting point about potentially doing a 0.9.1 vs 0.10.0. The 0.8.x
> >> branch seems to be running pretty parallel to the trunk, so it might
> >> be an interesting idea to keep the point release schedule and
> >> numbering somewhat aligned.
> >>
> >> Any other thoughts on that?
> >>
> >
> > Yeah, not sure. I think we've never really done an 0.x.1 release because
> so
> > much was always changing on the API. I know we had a few small-ish
> changes
> > this time, but nothing all that major, which made me think that an 0.9.1
> > would be okay. This felt like primarily a bug fix release.
> >
>
> I just took a look through the list of issues for what is currently
> called 0.10.0, and there are a few that were intentionally left out of
> the 0.8.x branch to avoid breaking compatibility. The ones I saw were:
>
> * CRUNCH-324 - Sample.reservoirSample method name is spelled incorrectly
> * CRUNCH-357 - Allow AvroMode overrides to be less global
> * CRUNCH-216 - Transpose arguments in MapsideJoinStrategy.join
>
> CRUNCH-324 and CRUNCH-357 are actual changes to the API, so people
> using those parts of the API won't be able to compile without updating
> their code -- however, the pieces of the API that are changed are
> probably not used by that many people. CRUNCH-216 added @Deprecated to
> one or two methods, with the intention of a gradual API change.
>
> This has me (mostly) convinced that we should do a 0.10.0 release
> instead of a 0.9.1 (although the bulk of the things are still bug
> fixes and improvements).
>
> - Gabriel
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message