crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriel Reid (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-357) Allow AvroMode overrides to be less global
Date Fri, 28 Feb 2014 18:04:19 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-357?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13916106#comment-13916106
] 

Gabriel Reid commented on CRUNCH-357:
-------------------------------------

+1 naming it "configure" or something along those lines.

Good point out how potentially invasive this change is. My feeling is that we should change
the "override" method name (maybe to something like "withFactory") and make the semantics
of the new method clear in the javadoc. Although this is a totally backwards-incompatible
change, it feels to me like it's an improvement, easy to migrate to, and will affect a very
small subset of users.



> Allow AvroMode overrides to be less global
> ------------------------------------------
>
>                 Key: CRUNCH-357
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-357
>             Project: Crunch
>          Issue Type: Improvement
>          Components: Core, IO
>            Reporter: Micah Whitacre
>            Assignee: Micah Whitacre
>         Attachments: CRUNCH-357.patch, CRUNCH-357_immutable.patch
>
>
> Currently consumers wanting to specify a custom reader must globally override the ReaderFactory
for a specific mode.  This means that if one AvroFileSource changes the factory it could affect
all other sources in the pipeline without anyone knowing it.
> One thought was what if a consumer could get a "local" AvroMode instance, configure it
to their needs and then specify that mode to the AvroFileSource to configure that source without
changing any global state.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message