crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Wills <jwi...@cloudera.com>
Subject Re: mvn javadoc issue
Date Fri, 02 Aug 2013 04:11:17 GMT
Yeah, that looks just like my setup. although I'm running the
javadoc:aggregate from the 0.7 branch, not trunk. I wonder if that has
something to do with it.


On Thu, Aug 1, 2013 at 8:40 PM, Gabriel Reid <gabriel.reid@gmail.com> wrote:

> Hey Josh,
>
> Just tried it on a Mac here, mvn javadoc:aggregate runs fine on trunk.
>
> I'm wondering if you just have to do a "mvn clean install" first (maybe
> the Avro jars aren't in your local repo and the javadoc plugin doesn't like
> that for some reason?)
>
>
> FWIW, my setup is as follows:
>
> greid$ java -version
> java version "1.6.0_51"
> Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
> Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)
>
> greid$ mvn -version
> Apache Maven 3.0.4 (r1232337; 2012-01-17 09:44:56+0100)
> Maven home: /usr/share/maven
> Java version: 1.6.0_51, vendor: Apple Inc.
> Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
> Default locale: en_US, platform encoding: MacRoman
> OS name: "mac os x", version: "10.8.4", arch: "x86_64", family: "mac"
>
>
> On 02 Aug 2013, at 05:17, Josh Wills <jwills@cloudera.com> wrote:
>
> > Hey guys,
> >
> > I am (slowly) following the release protocol, and was planning on pushing
> > the Javadoc for 0.7.0 to the site. But I just ran mvn javadoc:aggregate,
> > and got all of these weird failures, like this:
> >
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate
> (default-cli)
> > on project crunch-parent: An error has occurred in JavaDocs report
> > generation:
> > [ERROR] Exit code: 1 -
> >
> /Users/josh/dev/incubator-crunch/crunch-core/src/main/java/org/apache/crunch/impl/mem/MemPipeline.java:25:
> > package org.apache.avro does not exist
> > [ERROR] import org.apache.avro.Schema;
> >
> > I just upgraded my Mac, so I'm wondering if it's a java version issue.
> Does
> > anyone else see this?
> >
> > J
> >
> > --
> > Director of Data Science
> > Cloudera <http://www.cloudera.com>
> > Twitter: @josh_wills <http://twitter.com/josh_wills>
>
>


-- 
Director of Data Science
Cloudera <http://www.cloudera.com>
Twitter: @josh_wills <http://twitter.com/josh_wills>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message