crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gabriel Reid (JIRA)" <>
Subject [jira] [Commented] (CRUNCH-210) Update cogroup functions to use mapValues functions
Date Sun, 26 May 2013 06:08:21 GMT


Gabriel Reid commented on CRUNCH-210:

Looks good to me, other than one nitpick: I like the addition of a parameter to specify the
number of reducers, but I don't think that it should be called parallelism -- I would prefer
either numReducers or numPartitions. 

The only other place that the name "parallelism" is used is in Cartesian, and it has a totally
different meaning there, so I think using the same name here is confusing (it threw me off
when I first saw it in the patch).
> Update cogroup functions to use mapValues functions
> ---------------------------------------------------
>                 Key: CRUNCH-210
>                 URL:
>             Project: Crunch
>          Issue Type: Bug
>            Reporter: Josh Wills
>         Attachments: CRUNCH-210.patch
> Removing some deprecated MapValuesFn references in the CoGroup library and adding support
for users to specify an arbitrary level of parallelism on their CoGroup jobs.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message