crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Friedrich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CRUNCH-178) Add library functions for performing distributed reservoir sampling
Date Thu, 07 Mar 2013 07:24:12 GMT

    [ https://issues.apache.org/jira/browse/CRUNCH-178?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13595635#comment-13595635
] 

Matthias Friedrich commented on CRUNCH-178:
-------------------------------------------

No objections, just a question: With this class, we'll have two separate classes for sampling
that are named differently ("Sample" vs. "Sampling"). What about making this part of the existing
Sample class and maybe move implementation details out to a package-private class? Or even
start a new "sample" package if we expect more work in this area?
                
> Add library functions for performing distributed reservoir sampling
> -------------------------------------------------------------------
>
>                 Key: CRUNCH-178
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-178
>             Project: Crunch
>          Issue Type: Improvement
>          Components: MapReduce Patterns
>            Reporter: Josh Wills
>         Attachments: CRUNCH-178.patch
>
>
> For a project I've been working on, I wrote up some Crunch functions for performing reservoir
sampling and weighted reservoir sampling that I think would be useful enough to put in lib.*
Here's the paper that I used as a reference for the implementations I wrote:
> http://arxiv.org/pdf/1012.0256.pdf

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message