crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Friedrich <m...@mafr.de>
Subject Re: Building trouble
Date Sun, 31 Mar 2013 09:11:06 GMT
Hi Christian,

thanks! I installed the exact same Java and Maven versions that
gave me trouble on my laptop on a virtual server and there it
compiled fine. Difference being just the operating system version.
I've never seen a problem quite like it, this would be really
fascinating if it wasn't so annoying ;-)

Anyway, I'll try to track this down next week.

Regards,
  Matthias

On Saturday, 2013-03-30, Christian Tzolov wrote:
> Hi Matthias,
> 
> I've just repeated the exercise and for me it builds ok. Here is my
> configuration:
> 
> Maven 3.0.3
> Java: 1.6.0_43, vendor: Apple Inc.
> MacOSX, version: "10.8.3", arch: "x86_64", family: "mac"
> M2_OPTS=-Xmx2048m -XX:MaxPermSize=256m
> 
> 
> On Sat, Mar 30, 2013 at 4:33 PM, Matthias Friedrich <matt@mafr.de> wrote:
> 
> > Thanks for jumping with me, Josh, much appreciated! This is good news
> > though, it's probably some problem on my end. I have tried with
> > various JDKs and Maven versions, all with a clean repo, an empty
> > Maven cache, and under a new user account. I'll try again next week on
> > a different system; I brought depressingly little hardware on my
> > vacation.
> >
> > This must be revenge for doing next to no coding for way too long ;-)
> >
> > Regards,
> >   Matthias
> >
> > On Saturday, 2013-03-30, Josh Wills wrote:
> > > I opted to jump off a cliff with you-- deleted my m2 repository and
> > > then ran off mvn clean install. After downloading a copy of the
> > > Internet, I'm running the crunch integration tests, and everything
> > > looks fine. I'm assuming this error happens no matter which Crunch
> > > build profile you use? Were there any lingering target directories
> > > lying around that could be causing problems somehow?
> > >
> > > On Sat, Mar 30, 2013 at 2:13 AM, Matthias Friedrich <matt@mafr.de>
> > wrote:
> > > > Hi,
> > > >
> > > > I've got weird and potentially embarrassing build problems :)
> > > >
> > > > $ rm -r ~/.m2/repository
> > > > $ git clone https://git-wip-us.apache.org/repos/asf/crunch.git
> > > > $ cd crunch
> > > > $ mvn install
> > > > [...]
> > > > [ERROR]
> > > >
> > /tmp/crunch/crunch/src/main/java/org/apache/crunch/lib/sort/Comparators.java:[95,54]
> > > > cannot find symbol
> > > > [ERROR] symbol  : class WritableComparator
> > > > [ERROR] location: class org.apache.crunch.lib.sort.Comparators
> > > > [...]
> > > > $
> > > >
> > > > Obviously, WritableComparator is there, both in Hadoop 1 and 2 and
> > > > nobody touched dependencies in a while. I'm using Maven 3.0.4 and
> > > > Oracle JDK 1.6.0_33 which worked before.
> > > >
> > > > This popped up suddenly, probably around the time when I deleted my m2
> > > > cache for some reason (Jenkins is still happy, perhaps because we
> > > > don't clear the m2 cache). Older versions (before e20cbf08) worked
> > > > fine. Does this look familiar to anyone?
> > > >
> > > > Thanks,
> > > >   Matthias
> > >
> > >
> > >
> > > --
> > > Director of Data Science
> > > Cloudera
> > > Twitter: @josh_wills
> >

Mime
View raw message