crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul <rsha...@xebia.com>
Subject Re: [jira] [Commented] (CRUNCH-87) crunch-archtype fails with crunch.platform=2
Date Sun, 07 Oct 2012 18:24:47 GMT
Guys,

Sorry for replying quite late on this. But I think we can do pull 
something using the import scope of maven dependency management. I mean 
we can define all dependencies of archetype in dependency management 
section using crunch-parent in the following manner :

<groupid>o.a.c</groupid>
<atrifactid>crunch-parent</artifactid>
<type>pom</type>
<scope>import<scope>

The declaration above would import dependencies from crunch-parent, we 
can generate effective-poms  for both the profiles in the basic project 
to check. The dependencies here are correct as per the profile selected. 
Thus we can let the dependencies work via management section and delete 
versions from the artifacts.

I am not completely sure on this, but I think this is what we want to 
achieve.  I can give it a try tomorrow or the day after to see if it works.

regards,
Rahul

On 06-10-2012 23:39, Josh Wills (JIRA) wrote:
>      [ https://issues.apache.org/jira/browse/CRUNCH-87?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13471079#comment-13471079
]
>
> Josh Wills commented on CRUNCH-87:
> ----------------------------------
>
> +1 Matthias-- thanks for trying.
>                  
>> crunch-archtype fails with crunch.platform=2
>> --------------------------------------------
>>
>>                  Key: CRUNCH-87
>>                  URL: https://issues.apache.org/jira/browse/CRUNCH-87
>>              Project: Crunch
>>           Issue Type: Bug
>>     Affects Versions: 0.4.0
>>             Reporter: Josh Wills
>>             Assignee: Matthias Friedrich
>>          Attachments: CRUNCH-87-Fix-archetype-for-Hadoop-2.patch
>>
>>
>> Running:
>> mvn clean install -Dcrunch.platform=2
>> fails on the crunch-archetype submodule b/c the hadoop-core dependency doesn't exist
for Hadoop 2.0.0 (and I don't believe it's coming back.) Can we explicitly add hadoop-client
and the other dependencies the IDE would need to run the LocalJobRunner?
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA administrators
> For more information on JIRA, see: http://www.atlassian.com/software/jira


Mime
View raw message