crunch-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rahul Sharma (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CRUNCH-87) crunch-archtype fails with crunch.platform=2
Date Tue, 09 Oct 2012 03:48:03 GMT

     [ https://issues.apache.org/jira/browse/CRUNCH-87?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rahul Sharma updated CRUNCH-87:
-------------------------------

    Attachment: 0001-CRUNCH-87.patch

I have removed the version details that were in client pom. Instead I have imported all dependencies
form  crunch-parent. This way the version of hadoop is sent from parent pom. You can check
by using effective-pom with the crunch-platform variable.
If  the patch works then I think we can improve it a bit as imports a bunch of dependencies
which the client is not concerned of eg scala libs if you are using java.
                
> crunch-archtype fails with crunch.platform=2
> --------------------------------------------
>
>                 Key: CRUNCH-87
>                 URL: https://issues.apache.org/jira/browse/CRUNCH-87
>             Project: Crunch
>          Issue Type: Bug
>    Affects Versions: 0.4.0
>            Reporter: Josh Wills
>            Assignee: Matthias Friedrich
>             Fix For: 0.4.0
>
>         Attachments: 0001-CRUNCH-87.patch, CRUNCH-87-Fix-archetype-for-Hadoop-2.patch
>
>
> Running:
> mvn clean install -Dcrunch.platform=2
> fails on the crunch-archetype submodule b/c the hadoop-core dependency doesn't exist
for Hadoop 2.0.0 (and I don't believe it's coming back.) Can we explicitly add hadoop-client
and the other dependencies the IDE would need to run the LocalJobRunner?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message