creadur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Javen O'Neal" <javenon...@gmail.com>
Subject Re: [jira] [Commented] (RAT-220) JDK version 1.6
Date Sun, 11 Sep 2016 18:59:31 GMT
While increasing the minimum supported version does cut out some users who
are running ancient versions of Java, it also opens the door to better
language features. If the new features are used, it may be easier for
potential developers to read the code, contribute, and find bugs that are
disguised by the more verbose syntax of Java 1.5

You should consider both RAT developers and users when thinking about an
upgrade.

That said, Sebb is right that you should not increase the version without
significant thought, as it WILL abandon some users. If the only problem for
being on different versions is a more complicated compatibility statement
on your web page,  then leave this issue at that. "The Creadur project
consists of three modules: RAT, Whiskers, and Tentacles. RAT requires Java
6+. Whiskers and Tentacles requires Java 7+."

On Sep 11, 2016 11:40 AM, "P. Ottlinger" <pottlinger@apache.org> wrote:

> Hi!
>
> I tried bringing up this issue more than once, thus I was very happy
> that somebody else feels the same.
>
> In 0.12 we had a contribution that added a Gradle plugin. It failed due
> to insufficient dependencies with JDK5.
>
> Thus there's a need to update .... if we want to stay relevant.
>
> If we are happy with some rather old users with Ant and JD5 - ok,
> but to my mind we should add Gradle support to stay relevant in the ASF
> sphere.
>
> Just my 2 ct
> Phil
>
> Am 11.09.2016 um 14:56 schrieb Sebb (JIRA):
> >
> >     [ https://issues.apache.org/jira/browse/RAT-220?page=com.
> atlassian.jira.plugin.system.issuetabpanels:comment-
> tabpanel&focusedCommentId=15481714#comment-15481714 ]
> >
> > Sebb commented on RAT-220:
> > --------------------------
> >
> > +1
> >
> > We should not change the Java version merely to be consistent with other
> Creadur projects.
> >
> > There needs to be a clear end-user benefit to requiring the upgrade.
> >
> >> JDK version 1.6
> >> ---------------
> >>
> >>                 Key: RAT-220
> >>                 URL: https://issues.apache.org/jira/browse/RAT-220
> >>             Project: Apache Rat
> >>          Issue Type: Improvement
> >>            Reporter: Karl Heinz Marbaise
> >>            Assignee: Jochen Wiedmann
> >>
> >> Currently the RAT project defines as Java compatibility 1.5 but
> Tentacles defines 1.6 and Whiskers as well 1.6 so it would be a good idea
> to go to 1.6 as minimum....If someone needs to work with 1.5 toolchain can
> be used.
> >
> >
> >
> > --
> > This message was sent by Atlassian JIRA
> > (v6.3.4#6332)
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message